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License & Copyright 

Multiframe Program 

© 1985-2010 Formation Design Systems 

Multiframe is copyrighted and all rights are reserved. The license for use is granted to the 

purchaser by Formation Design Systems. As a single user license and does not permit the 

program to be used on more than one machine at one time. Copying of the program to 

other media is permitted for back-up purposes as long as all copies remain in the 

possession of the purchaser. 

 

Multiframe User Manual 

© 1985-2010 Formation Design Systems 

All rights reserved. No part of this publication may be reproduced, transmitted, 

transcribed, stored in a retrieval system, or translated into any language in any form or by 

any means, without the written permission of Formation Design Systems. Formation 

Design Systems, reserve the right to revise this publication from time to time and to 

make changes to the contents without obligation to notify any person or organization of 

such changes. 

 

DISCLAIMER OF WARRANTY 

Neither Formation Design Systems, nor the author of this program and documentation 

are liable or responsible to the purchaser or user for loss or damage caused, or alleged to 

be caused, directly or indirectly by the software and its attendant documentation, 

including (but not limited to) interruption on service, loss of business, or anticipatory 

profits. No Formation Design Systems distributor, or agent, or employee is authorized to 

make any modification, extension, or addition to this warranty. 
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About this Manual 

This manual is about Multiframe, a software system for structural analysis and design. 

 

Chapter 1 Getting Started 

Directs you to sources for installing and learning to use Multiframe. 

 

Chapter 2 Using Multiframe 

This chapter includes step-by-step instructions in using the program. This will explain 

most of the tasks you will carry out in defining, analysing and designing a structure. 

 

Chapter 3 Multiframe Reference 

Gives an overview of the operations of Multiframe and a summary of the commands 

used. 

 

Chapter 4 Multiframe Analysis 

Discusses the numerical methods used by Multiframe.  It is important for you to 

understand these methods and their limitations before using Multiframe for structural 

analysis and design.  The chapter ends with a summary of the capabilities and limitations 

of Multiframe. 

 

This manual describes the three versions of Multiframe, 2D, 3D and 4D.  Where 

appropriate the manual will indicate features that are only available in the 3D and 4D 

versions. 
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Chapter 1 Getting Started 

This chapter briefly describes where to find the relevant resources to  

 Installin g Multiframe  

 Learning Multiframe  

Installing Multiframe 

Instructions on installing and starting Multiframe can be found in the Installation Guide 

included in the package you received with the installation CD and copy protection 

device. Alternatively, you can also consult the installation guide online: 

http://www.formsys.com/installation. 

Learning Multiframe 

The best way to learn to use Multiframe is going through the ñLearning Multiframe ò 

tutorials. These take you through all the basics of working with Multiframe from starting 

the application to modelling a simple 2D or 3D structure. The tutorials are supported by 

videos. These videos can be installed by installing ñLearning Multiframeò from the 

installation CD or after downloading the installer from the web. Alternatively, the entire 

training, including videos, can be viewed online.  

 

Go to the Learning Multiframe page on our website for the installer download and / or 

start the tutorials online: http://www.formsys.com/mflearning. 

 

Within Multiframe, the Learning Multiframe training can be accessed from: 

 Help menu in Multiframe  

 Start menu | Programs | Multiframe | Help (only when Learning  Multiframe has been 

installed)  

 

Both new users as well as experienced Multiframe users will benefit from working 

through this training document. 

 

Continue reading:  

 Chapter 2 Using Multiframe ; series of step -by-step instructions on specific tasks in 

Multiframe.  

 Chapter 3 Multiframe Reference ; lists all menu commands available in Multiframe.  

 Chapter 4 Multiframe Analysis ; explains the m atr ix calculation methods used in 

Multiframe including sign conventions etc.  

 

http://www.formsys.com/installation
http://www.formsys.com/mflearning
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Chapter 2 Using Multiframe 

After doing Learning Multiframe tutorials (see Chapter 1 Getting Started for more 

information) you should now have a basic knowledge of some of the features of 

structural analysis and design using Multiframe.  This chapter presents a series of step-

by-step instructions to the tasks covered in Learning Multiframe as well as other 

procedures you will want to know about. 

 

The chapter begins with a summary of basic computer skills, and this is followed by a 

description of the tasks involved in analysing and designing a structure using 

Multiframe.  These tasks fall into three general categories; Creating the structure, 

specifying the loads and interpreting the results of analysis.  The first three sections of 

this chapter reflect these categories.  This is followed by detailed explanations of doing 

design calculations, printing and saving data and transferring data to other programs. 

 Techniques  

 Using Views  

 Creating a Structure  

 Applying Loads  

 Analysis  

 Viewing Results  

 Printing  

 Data Exchange  

Techniques 

There are several techniques you can use in Multiframe to make modelling structures fast 

and intuitive.  In this section you will learn about the different mouse and keyboard 

techniques available in Multiframe.  

 Summary of Mouse Techniques  

 Summary of Keyboard Techniques  

 

Summary of Mouse Techniques 

You will use the following mouse techniques to do just about all of the tasks in this 

chapter. 

 

 Click to select or activate something  

 Press to cause a continuous action  

 Drag to select, choose from a menu or move something  

 Shift -Click to select or to extend or reduce a selection  

 Ctrl -Click to select or to extend or reduce a selection  

 Double click to get information about an object  

 

To Click 

Position the pointer on what you want to select or activate 

Press and quickly release the mouse button 

To Press 

Position the pointer on something 
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Without moving the mouse, press and hold down the mouse button 

 

The effects of pressing continue as long as the mouse button is held down. 

Pressing on a scroll arrow results in continuous scrolling. Pressing on a menu title 

pulls down the menu and keeps it down until you release the mouse button. 

To Drag 

Position the pointer on something 

Press and hold down the mouse button and move the mouse 

Release the mouse button 

To Shift-Click 

Shift-click is used to extend or reduce the selection of joints and members 

Hold down the shift key and click on the joints or members you wish to add to the 

selection or which you wish to remove from the selection 

To Ctrl -Click 

Ctrl-Click is used to extend or reduce the selection of joints and members 

Hold down the Ctrl key and click on the joints or members you wish to add to the 

selection or which you wish to remove from the selection 

To double click 

Double click is used to get information about a joint or member in the Frame 

window 

Point to the item you wish to double click and then click twice quickly in 

succession without moving the mouse. 

Summary of Keyboard Techniques 

Tab 

You can use the Tab key to move horizontally within a table or to move from one 

field in a dialog to the next. 

Enter 

The Enter key can be used to confirm the entry of numbers into a table and is the 

same as clicking OK in a dialog. 

Arrow Keys 

The keys may be used to move the selection in their respective 

directions in the Data or Result tables or in tables in dialog boxes. 

Delete  - Backspace 

The Delete or Backspace key may be used to delete the current selection.  If 

nothing is selected and you are typing text or numbers, it will delete the character 

to the left of the blinking cursor. 

Ctrl  

The Ctrl key may be held down while typing another key to choose a command 

from a menu without using the mouse.  Menu items that have a key to the right of 

the name may be chosen in this way.  For example, to choose Undo from the Edit 

Menu you could hold down the Ctrl key and type Z. 

Shift or Ctrl  

You can hold down the Shift or Ctrl keys while clicking on something to add it to 

the current selection or remove it from the selection if it is already selected. 

 

Holding down the shift or Ctrl while drawing a member, dragging a member or 

dragging a joint will constrain the movement to be horizontal, vertical or at a 45 

degree angle. 
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Home 

Takes you to the top of the table in the Data and Result windows. 

F2 function key 

Shortcut key to execute a Linear Analysis. 

 

Using Views 

There are a number of tools in Multiframe to help you view your frame. This section 

describes different utilities to display your structural model 

 View Directions  

 Rotating a 3D View  

 Zoom, Pan, Shrink and Size To Fit  

 Clipping and Masking  

 Rendering  

 Selecting Joints and Members  

 Selecting Load Panels  

 Selecting Patches  

 Selecting Pl ates 

 Symbols  

 Legend  

 

View Directions 

The View button in the bottom left hand corner of the Frame, Load and Plot windows 

can be used to display a range of two and three-dimensional views of a structure.  Each 

window has its own view and is controlled separately by its view button. 

 

You can change the view by clicking on the View button and then clicking on the icon of 

the view you require. You can also change the view by using the View3D toolbar. 

 

The view may also be changed via the Current View submenu in the View menu. 
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Rotating a 3D View 

When you have a 3D view displayed in the Frame, Load or Plot windows, you can 

control the angle of view by using the rotation controls at the bottom and right sides of 

the window.  The axes indicator indicates the current angle of view. 

 

The control at the bottom controls the rotation about the y axis while the control on the 

right hand side controls the rotation about the x axis.  You can click in the control to 

move the angle of rotation to the position of the mouse.  If you hold down the mouse 

button after clicking in the control, you can rotate the structure back and forth until you 

have the desired angle of rotation.  If your structure is too large to draw rapidly as you 

rotate it, Multiframe will draw a partial outline of the frame. 

Zoom, Pan, Shrink and Size To Fit 

The Zoom, Pan, Shrink and Size To Fit commands in the View Menu may be used to 

control the scale of the graphics displayed in the Frame, Load and Plot windows.  Each 

view within a window has its own scale and centre of interest. This means you can have 

a close-up plan view and a far away 3D view in the same window and simply switch 

from one to another using the View button. You can also select these commands from the 

View toolbar. 

 

Zoom 

Zoom allows you to increase the size of the drawing in the front window. 

ü Choose Zoom from the View Menu 

ü Move the pointer to the top left hand corner of the area you wish to view 

in close detail 
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ü Drag a rectangle down and to the right which encloses the area of interest 

and release the mouse button 

 

The window's contents will be re-drawn to display the part of the structure contained in 

the rectangle you have drawn. 
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If the mouse you are using has a wheel it can be used to dynamically zoom the view. 

Pan 

Pan allows you to shift the display of the structure within the window upwards, 

downwards, to the left or right. 

ü Choose Pan from the View Menu 

The cursor will change to a four arrowed cursor 

ü Press inside the window and hold down the mouse button 

 

ü Drag the drawing to its new location 

ü Release the mouse button to re-draw the contents of the window. 
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You can use the Ctrl-E keyboard shortcut to use the Pan command. 

 

If not enough memory is available to move the image, a rectangle the size of the window 

will be moved around as you move the mouse. 

Shrink 

Shrink allows you to decrease the size of the drawing on the screen by 50%. 

ü Choose Shrink from the View Menu 

The drawing will shrink down to 50% of its current size and be re-drawn. 

   

 

If the mouse you are using has a wheel it can be used to dynamically zoom or shrink the 

view. 
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Size To Fit 

Size To Fit automatically resizes the drawing in the front window so that the structure 

just fits inside the window in the current view.  This is most useful after you have been 

zooming, panning or shrinking as it returns you to a viewing scale that just fits the frame 

inside the window. 

 

Size To Fit Frame fits the whole frame inside the window. 

 

Size To Fit Selection fits the selected members and joints inside the window. 

 

Size To Fit Clipping fits the range of clipping inside the window. 

 

The Home key can be used as a short cut to the Size to Fit command.  

Clipping and Masking 

Multiframe allows you to control how much of the structure you wish to view at one time 

by use of two techniques named clipping and masking.  Clipping allows you to define a 

three dimensional box which encloses the part of the structure you wish to work with 

while masking allows you to selectively show or hide any member or group of members 

in the structure. 

 

For example, suppose you wish to view the bending moment diagram for a given column 

line in a frame. Without clipping, the diagram is very difficult to decipher.  However, if 

you select the column line and then choose Clip to Selection from the Clipping sub-menu 

under the Edit menu, the diagram is made much clearer. Masking may be used in a 

similar way.  When a member is grey or hidden because of clipping or masking, it cannot 

be selected or moved with the mouse. 

Clipping 

You can control the clipping of the structure in any of the two dimensional views in a 

window.  The clipping affects the display of graphics in the Frame, Load and Plot 

windows.  This means that you can use the clipping controls in a view of one window to 

make it easier to see the graphics in a different view of another window.  There are two 

types of clipping, clipping which draws the clipped out part of the frame in grey, and 

clipping which makes the clipped out members completely invisible. 

 

When clipping is turned on, the clipping bars are displayed as dotted lines in the two 

dimensional view.  These dotted lines represent the boundaries of the clipping box. 
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To change the boundaries of the clipping box, and therefore change which members in 

the structure are visible, you can press and drag on the bars with the mouse. 

 

 

 

If you want to move two bars simultaneously, you can press and drag on the intersection 

between the two bars and drag them at the same time. 
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The small triangles located between the clipping bar on the edges of the window indicate 

the drawing depth.  These can also be dragged using the mouse and to help align the 

drawing depth accurately the mouse will snap to objects and grids. 

Clip To Frame 

Usually you will find it convenient to start by choosing Clip To Frame from the Clipping 

menu.  This positions the clipping bars so that they lie just outside the outer boundaries 

of the frame.  You will then find it easy to move the appropriate bar to restrict your 

viewing to the part of the frame that is of interest to you. 

Clip To Selection 

You will also find it convenient to use the Clip To Selection command from the Clipping 

menu.  This will position the clipping bars so that they lie just outside the farthest extents 

of the currently selected joints. 

 

If you try to move a clipping bar past the position of its opposing bar (for example, move 

the bottom bar up past the top bar) the opposing bar will be moved to maintain a small 

distance between the two.  This can be very useful when you want to move clipping from 

one floor to another or from one column line to another.  You can clip on the bar farthest 

from the direction you wish to move and drag the two bars together. 
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Clipping Zones 

Clipping regions can be saved within Multiframe and used to restore clipping to a 

predefined region.  This enables the user to quickly restore clipping to a particular part of 

the model.  A clipped region is stored within Multiframe as Clipping Zone.  

 

To save the current clipping region 

ü Choose Save Clipping Zoneé from the Clipping submenu in the View 

menu 

ü Enter a name to identify the saved region 

 

ü Click the OK button  

The current clipping regions can readily be restored to a region stored as a clipping zone. 

 

To modify a zone 

ü Choose Save Clipping Zoneé from the Clipping submenu in the View 

menu 
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Clipping zones are particularly useful when working with 3D models as separate zones 

can be defined for each of the 2D frames that make up the model. Each of these frames 

can then be quickly accessed by simply clipping to each of the zones 

Masking 

Masking allows you to control the visibility of the structure by selecting members and 

then choosing to show or hide them.  If you use the Mask To Selection command in the 

Masking menu, this will hide all of the members in the structure except those which are 

selected. If you choose Mask Out Selection, the selected members will be hidden and the 

remaining visible members will remain visible. 

 

Like clipping, masking affects the display of graphics in the Frame, Load and Plot 

windows and can also be used in a view of one window to make it easier to see the 

graphics in a different view of another window.  Masking can also be grey or invisible 

however Multiframe will always ensure that clipping and masking both use the same 

display method. i.e. either both will display in grey or both will make hidden members 

invisible. 

 

Masking is useful for situations where the area you wish to view is not rectangular in 

shape and therefore is not suitable for clipping. 

Rendering 

Multiframe3D and Multiframe4D allow you to render the display of the frame in the 

Frame, Load and Plot windows as an aid to visualising the relative sizes and orientation 

of the sections in the structure.  Rendering involves drawing a representation of the 

frame, complete with web and flange details, with hidden lines removed.  Rendering can 

only be done in the 3D view in a window and only on the Deflection diagram in the Plot 

window.  The number of segments drawn per member on the rendered, deflected shape is 

controlled by the precision set using the Ploté command from the Display menu. 

 

To turn on rendering in the front window 

ü Choose Render from the Display menu 

A dialog will appear with the rendering options. 



Chapter 2 Using Multiframe  

Page 17 

 

ü Check the Render Members check box to turn on the rendering 

If you wish you can also choose whether to use shading on the sections and whether to 

draw separate lines for the edges of the sections. 

 

The Section scale field can be used to exaggerate the sizes of the section shapes as they 

are drawn in the rendered view.  Because the size of sections is usually very small 

compared to the size of the frame, this helps make the actual shapes more clearly visible. 

 

The Rendered length field can be used to shrink the rendered length of the members back 

from their actual end locations. This can help to visualise the orientation and position of 

members at a joint. 

 

The OpenGL check box allows you to turn on and off the use of OpenGL rendering. This 

provides high speed rendering with most graphics cards and also allows use of 

transparency with clipping and masking. You will need to run off OpenGL rendering to 

print a rendered view to a printer. 

ü Click the OK button  

The structure will be drawn using rendering until you turn rendering off. To turn off 

rendering, choose the Render command and turn off the Hidden Lines check box. 
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If you have clipping or masking turned on, rendering will only render the visible 

members.  If you have drawn custom sections using Section Maker, rendering will 

display the actual shape of the custom section.  Circular sections are displayed 

approximately as octagonal shapes. 

Selecting Joints and Members 

There are many techniques and commands that are used to selecting joint and members 

within a graphical window.  The most common way of selecting items is by using the 

mouse.  To select a single item 

ü Click on the item 

The selected item is draw as using a thicker line size to make it appear bold.  Typically 

this will be drawn in black but a different colour for drawing the selection can be set via 

the Colour command in the View menu. 

 

To extend or reduce the selection 

ü Shift-click on an unselected item to add it to the current selection 

ü Shift-click on a selected item to remove it from the current selection 

To select a group of items 

ü Drag a rectangle which encloses the items to be selected 

If the rectangle is defined by dragging the cursor from the left to the right, a bounding 

selection will be performed and only the items within the rectangle will be selected.  If 

shift is held down while dragging, the existing selection will be extended with the 

additional unselected items that are contained within or intersect the rectangle. 

 

When performing a drag selection there are two techniques for items. The first is by 

using a rectangular box as described above.  An alternative to this is to use a line 

selection in which the user drags the end of a straight line across the screen. In this case 

all members that intersect this line are selected and well as all joints connected to these 

members. 

 

The selection tool to be used when performing a drag selection is picked using the View 

Toolbar. Clicking on the dotted square or dotted line buttons chooses the corresponding 

selection tool. 

 

The Select menu contains a number of commands for helping to select items in the 

model.  Member and Joint may be selected by specifying their number or by a label.  

Selecting Load Panels 

There are many techniques and commands that are used to selecting load panels within a 

graphical window.  The most common way of selecting items is by using the mouse.  To 

select a single item 

ü Click on the item 

The selected panel is draw with dark pink colour to make it appear highlighted, but a 

different colour for drawing the selection can be set via the Colour command in the View 

menu. 
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To extend or reduce the selection 

ü Shift-click on an unselected panel to add it to the current selection 

ü Shift-click on a selected panel to remove it from the current selection 

ü Shift-drag to invert the selection in the selection rectangle 

To select a group of items 

ü Drag from left to right a rectangle which encloses the panels to be selected 

ü Drag from right to left t o select all load panels which intersect or are 

contained inside the selection rectangle 

 

If the rectangle is defined by dragging the cursor from the left to the right, a bounding 

selection will be performed and only the items within the rectangle will be selected.  If 

shift is held down while dragging, the existing selection will be extended with the 

additional unselected items that are contained within or intersect the rectangle. 

 

When performing a drag selection there are two techniques for items. The first is by 

using a rectangular box as described above.  An alternative to this is to use a line 

selection in which the user drags the end of a straight line across the screen. In this case 

all members that intersect this line are selected and well as all joints connected to these 

members. 

 

Selecting Patches 

There are several techniques and commands that are used to select patches within a 

graphical window.  The most common way of selecting items is by using the mouse.  To 

select a single item 

ü Click on the item 

The selected patch is drawn in a darker colour . A different colour for depicting the 

selection can be set via the Colour command in the View menu. 

 

To extend or reduce the selection 

ü Shift-click on an unselected patch to add it to the current selection 

ü Shift-click on a selected patch to remove it from the current selection 

ü Shift-drag to invert the selection in the selection rectangle 

To select a group of items 

ü Drag from left to right a rectangle which encloses the patches to be 

selected 

ü Drag from right t o left to select all patches which intersect or are 

contained inside the selection rectangle 

 

If the rectangle is defined by dragging the cursor from the left to the right a bounding 

selection will be performed. Only the items within the rectangle will be selected. 

 

If the rectangle is defined by dragging the cursor from right to left an intersect selection 

will be performed. Any item that intersects the rectangle will be selected. 
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If shift is held down while dragging, the existing selection will be extended with the 

additional unselected items. 

 

A second technique for performing a drag selection is to use a line selection. When the 

line selection tool is chosen the user drags the end of a straight line across the screen. All 

patches that intersect this line and all joints connected to these patches are selected. 

 

Selecting Plates 

There are several techniques and commands that are used to select plates within a 

graphical window.  The most common way of selecting items is by using the mouse.  To 

select a single item 

ü Click on the item 

The selected plate is drawn in a darker colour . A different colour for depicting the 

selection can be set via the Colour command in the View menu. 

 

To extend or reduce the selection 

ü Shift-click on an unselected plate to add it to the current selection 

ü Shift-click on a selected plate to remove it from the current selection 

ü Shift-drag to invert the selection in the selection rectangle 

To select a group of items 

ü Drag from left to right a rectangle which encloses the plates to be selected 

ü Drag from right to left to select all plates which intersect or are contained 

inside the selection rectangle 

 

If the rectangle is defined by dragging the cursor from the left to the right a bounding 

selection will be performed. Only the items within the rectangle will be selected. 

 

If the rectangle is defined by dragging the cursor from right to left an intersect selection 

will be performed. Any item that intersects the rectangle will be selected. 

 

If shift is held down while dragging, the existing selection will be extended with the 

additional unselected items. 

 

A second technique for performing a drag selection is to use a line selection. When the 

line selection tool is chosen the user drags the end of a straight line across the screen. All 

plates that intersect this line and all joints connected to these plates are selected. 
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Symbols 

The information displayed in the graphical windows may be modified by the user via the 

Symbols Dialog. This dialog is accessed via the Symbols command in the Display menu.  

 

 

 

This dialog has options to display information related to the joints, members and panels 

in the model. For joints, this includes the properties of the joint such as its number, label 

or local axes.  Other symbols can be displayed to indicate other information related to 

joints such as restraints, joint masses, and linked joints.  Similar options are available for 

members and panels; they may be displayed with their number, label, length and local 

axes.  They may also be annotated with their section names or shapes.  Symbols 

representing other properties that are related to the ends of the members may also be 

shown an include end releases and offsets. 

 

Other setting available via this dialog allow the display in the plot and loads windows to 

be customised.  A number of options are available that specifies how and if loads are 

display and whether the loads are labelled with their magnitudes.  Similar options are 

available for controlling the display of reactions and labels in the Plot window. 

 

The colour used to draw each element in the Frame window is also set via the Symbols 

dialog.  Members in the Frame window can be displayed using a number of colouring 

schemes that use different colours to distinguish members based upon their section, 

section shape or label.  Grouping of members may also be highlighted by displaying 

members using the colour of the group in which they are contained.  A legend 

summarising the colours used in drawing the model may also be displayed. 

 

The symbols toolbar provides a number of buttons to toggle the display of the more 

frequently used symbols. 
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Legends 

Legends displaying the meaning of colours used to display members and loads can be 

displayed by selecting the corresponding option in the Symbol Display dialog available 

from the Display menu. 

 

A feature of some of the legends used in Multiframe is that you can use the legend to 

modify the selection in the current window.  Double clicking on the text of an item in the 

legend will select the corresponding items in the model.  For example, this can be useful 

for selecting all the members in a group, all the members with the same label or all he 

members with the same section type. 

Member Legend 

Members in the Frame and Plot window can be displayed in colour.  The colour of the 

member is selected via the Symbol Display dialog (available from the Display menu) by 

choosing a colour scheme. The following options are available: 

Default colour 

When this option is selected, the default colour settings will be used. The default 

colour settings can be set via the View | Colour dialog.  

Section 

When this option is selected, the membersô colour will be displayed as per the 

colour of the Section type. The legend will list all different section types used in 

the structure. 

Section Group 

When this option is selected, the membersô colour will be displayed as per the 

colour of the group their assigned section type belongs to. The legend will list all 

different section groups that the members used in the structure belong to. Section 

groups are for example UB, Channels, Equal Angles etcetera.  

Section Shape 

When this option is selected, the membersô colour will be displayed as per the 

colour of the shape. The legend will list all different shapes of the members used 

in the structure. Shapes are for example Tube, I section, Channel, etcetera.  

Label 

When this option is selected and members have been labelled, the membersô 

colour will be displayed as per the label colour. The legend will list all different 

labels.  

Type  

When this option is selected, the membersô colour will be displayed as per the 

member type colour. The legend will list the different types of members used in 

the structure. Types are for example ñTension onlyò or ñCompression onlyò. 

Group (in current group set) 

When this option is selected and members have been assigned to groups, 

membersô colour will be displayed as per the group they belong to. The legend 

will list all different groups used in the current group set. For more information on 

Groups and Group Sets, please see Grouping on page 74. 

Component 

When this option is selected and members have been assigned to components, the 

membersô colour will be displayed as per the componentôs colour. The legend will 

list all different components. 
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Tip 

You can use the legend to quickly select members that share the same 

property or label. For example: if you want to select all members with a 

Tube shape, you set the Colour scheme to Shape in the Display | Symbols 

dialog and then double click on ñTubeò in the legend. 

Load Legend 

The colour used to display each load in the Load Window is set by selecting the colour 

scheme in the Symbol Display dialog (available from the Display menu). As with 

members, various properties of the loads can be displayed graphically. The following 

options are available: 
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Load type 

Display the colour of the load by the Load type. Load types are for example: Local 

Member Point Loads, Local Joint Loads etcetera.  

Direction 

Display the colour of the loads by the direction the load is in.  

Localised index 

When several loads are applied on one member, their display can be set so that the 

1
st
, 2

nd
, 3

rd
, é loads on each member are shown in different colours. 

Loadcase  

Display the colour of the loads by base load case from which load originates. 

Loading type 

Display the colour of the loads by the Loading type. Loading types can be for 

example dead, live, etc 
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Note 

The Load legend is activated by selecting the check box next to the load 

colour scheme in the Symbol Display dialog (available from the Display 

menu). 

Legend Properties 

Legends are drawn in the corners of a window, by default this is the top right hand 

corner. The position of the legends can be modified by the user via the Legend submenu 

contained within the Display menu.  The font size and style used to draw the legend can 

also be customised using the commands in the Legend submenu. 

 

In many instances it is also possible to customise the colour of each item in the legend. 

This can be done via the submenu or by double clicking on the colour box in the legend.  

Note that many legends use the same list of legend colours and that editing the colour of 

an item in one legend will be affect the colour in many legends.  

 

A popup menu can also be activated by right clicking the mouse on the legend. The 

popup menu has options to edit the colours, style and position of the legend and to 

choose the current colour scheme. 

Creating a Structure 

Creating a structure with Multiframe involves defining the geometry, restraints, section 

types and the connections of the structure by drawing in the Frame window.  You can 

also use the pre-defined generation aids to automatically construct portal frames or 

geometrically regular structures. 
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This section begins with a description of the drawing techniques you can use to create a 

structure.  This is followed by a summary of how to select joints and members in the 

structure and how to use Multiframe capabilities to assist in generating commonly used 

structures.  A description of the commands that can be used to specify data defining 

restraints, section properties and members with pins or moment releases, completes the 

section. 

Drawing 

Members of the structure may be drawn directly by using the mouse to define the 

beginning and end points of a member.  The scale at which this drawing is carried out 

may be specified by choosing the Sizeé command from the View Menu.  The maximum 

and minimum coordinates to be used in the x, y and z directions may be entered and 

Multiframe will scale these coordinates to the current size of the Frame window.  All 

movements in the window are accompanied by a display of the current pointer 

coordinates in the lower left hand corner of the window.  All coordinates are shown in 

the current length units as set using the Units command from the View menu. 

 

Similar to membersô drawing, load panels can also be drawn directly by using panel 

drawing commands from the Geometry Menu or shortcuts.  The panels can be either 

triangle or quadrilateral, but have to be planar.    

 

Patches can also be drawn directly by using patch drawing commands from the 

Geometry Menu or shortcuts.  The patches can be either triangle or quadrilateral, but 

have to be planar. 

 

Setting the Size 

Before starting drawing, you will need to set up the drawing area for the size of frame 

you intend working with. To do this 

ü Choose Sizeé from the View Menu 

A dialog box will appear with the dimensions of the structure. 

ü Enter the maximum and minimum coordinates you wish to use in each 

direction 

ü Click the OK button  

 

Drawing Grid 

Multiframe has a built-in facility to allow you to have your drawing automatically align 

with an evenly spaced grid.  You can control the spacing, display and use of this grid 

with the Gridé command from the View Menu. 
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ü Choose Gridé from the View Menu 

 

ü Enter values for the x, y and z spacing of the grid 

ü Click on the Visible checkbox if you want the grid to be displayed in the 

Frame Window. 

ü Click on the Snap checkbox if you want drawing to align to the grid. 

ü Click the OK button  

If you want to have the joints automatically align with the grid, but do not want to see the 

grid, simply unselect the Visible button before clicking OK.  Similarly you can select the 

Visible  to have the grid displayed as a visual guide, but unselect the Snap  to disable the 

automatic alignment with the grid. 

Structural Grid 

Multiframe also has a facility to define a 3D structural grid that allows you to have your 

drawing automatically align with a predefined grid associated with the building.  

 

The structural grid is composed of a number of planar grids that nominally represent a 

floor within your building.  You can control the size, location, labelling, and use of these 

grids with the Structural Gridcommand in the View Menu.  

ü Choose Structural Gridé from the View Menu 
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The Grid Manager dialog appears that allows you to add, edit, delete and modify the 

behaviour of grids. 

 

The table of grids can be used to directly edit some properties if the individual grids that 

make up the structural grid.  The behaviour and display of each grid can be controlled 

individually.  As with the drawing grid, if you want to have the joints automatically align 

to a grid, but do not want to see the grid, simply unselect the Visible button before 

clicking OK.  Similarly you can select the Visible  to have the grid displayed as a visual 

guide, but unselect the Snap  to disable the automatic alignment with the grid. 

 

Adding a Grid 

To add a new grid 

ü Click on the Addé button 

The Structural Grid dialog is displayed which is used to define the properties of the new 

grid. 
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ü Enter the name of the grid 

ü Choose orientation of the grid by selecting a plane. 

ü Specify the position of the grid by setting the location of the grid along the 

axis perpendicular to the plane of the grid. 

ü For each of the two directions in the plane of the grid specify the number 

of grid line and there location. 

ü Click the OK button  

Editing a Grid 

To edit an existing grid 

ü Select the row in the table of grids corresponding to the grid to be edited. 

Alternatively just a cell in this row can be selected. 

ü Click on the Edité button 

The Structural Grid dialog is displayed which is used to modify the properties of the grid 

(see above). 

Deleting a Grid 

To delete an existing grid 

ü Select the rows in the table of grids corresponding to the grids to be 

deleted.  

ü Click on the Deleteé button 
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You will be prompted to confirm that you wish to delete the selected grids.  

Duplicating a Grid 

To edit an existing grid 

ü Select the rows in the table of grids corresponding to the grids to be 

duplicated. 

ü Click on the Duplicateé button 

 

ü Enter the number of times to duplicate the grids 

ü Enter the distance to increment the position of the duplicated grids. 

ü Click the OK button  

Drawing Depth 

When you draw in a two dimensional view it is necessary to specify the depth at which 

you are drawing.  For example, when drawing in the Top view, the y coordinate must be 

specified for any members drawn. 

 

To change the current drawing depth 

ü Choose Drawing Depthé from the View menu 

A dialog box will appear with the current depth selected. 

 

Type in a new value for the depth and click OK to set the new depth. 

Snapping to Joints and Members 

Drawing in Multiframe will also automatically align to joints and members in your 

model.   

 

You can control which parts of the model the cursor will snap to when drawing via the 

Drawing Settings dialog from the Geometry menu.  This dialog gives you options to snap 

to 



Chapter 2 Using Multiframe  

Page 31 

 Joints  

 Members  

 Member quarter points  

 A cus tomised number of points along members  

 Perpendicular point on member  

The option to snap to a perpendicular point on a member is only used to snap the second 

end of a line been drawn such that the line is drawn perpendicular to the existing 

member. 

 

When drawing in a 3D view the drawing defaults to be located in the current working 

plane. This plane is the plane oriented most perpendicular to the current viewing 

direction which passes through the current drawing depth.  The axes indicating the origin 

of the coordinate system highlight the axes that identify the orientation of the drawing 

plane.  When the cursor snaps to an existing item in the model the drawing will snap to 

this point in 3D space. 

 

When drawing is a 2D view snapping to existing pasts of the model out of the current 

drawing plane can be a problem.  For example, when trying to draw a planar structure in 

front of an existing part of the model the cursor may snap to existing objects which can 

move the drawing from the current working plane.  To avoid this problem all drawing 

can be forced to occur in the current working plane by selecting the óConstrain drawing 

to working plane optionô in the Drawing Settings dialog.  When this option is selected, 

the cursor will still snap to existing parts of the model but drawing will be projected back 

to the current drawing depth. 

 

When drawing or dragging you can stop the cursor snapping to joints, members and grid 

points by simply holding down the ALT key while performing the operation. 

Dynamic Line Constraints 

By default, drawing will occur on the current working plane which is the plane aligned 

with the global axes, that is most normal to the current viewing direction and passing 

through the current drawing depth.  To help with the alignment of the model and to allow 

drawing out of the current working plane Multiframe uses dynamic line constraints.  

When drawing a member, if the cursor has snapped to a joint and the mouse moved in 

the direction of one of the global axis, drawing will be constrained to occur along this 

direction in 3D space. 

 

The constraint of drawing to the global axis direction described above is in fact part of a 

more general concept for automatically constraining the direction the mouse moves in 

3D space.  The drawing direction can also be constrained to occur in the direction of 

members connected to a joint. If the mouse is moved in the direction of a member 

attached to the joint then drawing will be constrained to the direction of that member in 

3D space. 

 

When movement is constrained the direction of a global axis or element, a small arrow 

will be drawn at the cursor pointing in the direction of the line of the constraint. The 

colour of the arrow indicates is the constraint is in the direction of a global axis or a 

member. 
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The drawing constraint will be deactivated if the cursor is moved to far away from the 

direction of the constraint. This can be avoided by holding down the shift key and this 

will force the current restraint to remain active. 

 

Dynamic line constrains can be disabled via the new Drawing Settings dialog. 

Drawing Settings 

The Drawing Setting dialog from the Geometry menu allows you to modify options 

associated with snapping to objects in the model, the use of dynamic line constraints and 

other options associated with graphically interacting with the model. 

 

The Lock Geometry option in this dialog provides a means for stopping the geometry 

and topology of the frame from being modified.  This includes disabling all drawing, 

dragging and generation of structural members. 
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This dialog also provides some options for controlling how far the cursor will move to 

snap to an object in the model.  The Joint snap tolerance specifies how close the cursor 

has to be to a joint to snap to the joint. Similarly the Member snap tolerance specifies 

how close the cursor has to me to a member (or point on a member) to snap to the 

member.  In general the member snap tolerance should be equal to or smaller than the 

joint snap tolerance.  By default these values are quite small but for most models 

tolerances of 20 pixels or greater can be used. 

Setting the Origin 

Multiframe has an origin for its coordinate system indicated by a symbol of x, y and z 

axes drawn in the Frame window.  You can control the display of these axes by using the 

Axes command from the View Menu. 

 

You can also change the location of the origin, relative to a structure. 

ü Choose Move éfrom the Geometry menu 

A dialog box will appear allowing you to enter x, y and z coordinates for the new 

position of the origin. 

 

This command is useful for creating structures that are made up of larger sub-structures. 

You can shift the origin to a convenient location prior to doing the drawing for each sub-

structure. 

 

Adding a Member 

To add a member to the structure 

ü Choose Add Member from the Geometry menu 

ü Or Click on the Add member icon in the Member toolbar 

ü Move the pointer to the position of the first joint 
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ü Press the mouse button and drag to the position of the second joint 

(Windows users have the option of just clicking on the first joint instead of 

dragging) 

Exist ing member in  the frame

 

ü Release the mouse button  (You also have the option of just clicking on the 

second joint to complete the new member) 

New member is
drawn here

Members wi ll  be connected
at this joint

 

Holding down the shift key while drawing a member constrains the new member to be 

either vertical or horizontal or at 45 degrees. 

 

When you draw the new member, the coordinates of the mouse will be displayed in the 

bottom left corner of the window.  Also, the distance and slope of the current position of 

the mouse from the last point will be displayed. 

 

When drawing in the 3D view, you can only draw a member between two existing joints. 

 

If the grid is turned on while you draw the member, the position of the joints will snap to 

the grid.  The depth of the member will depend on the setting of the depth for the current 

view.  See Depth above for an explanation of how to set this depth. 

Adding a Load Panel 

There are several ways for users to add a load panel to the structure.  From Geometry 

Menu, a user can: 

ü Choose Add rectangle Load Panel from the Geometry menu 

ü Click on two nodes at diagonally opposite corners of the panel. 
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To add a triangular load panel 

ü Choose Add 3-node Load Panel from the Geometry 

ü Click in anti -clockwise order the three nodes that define the corners of the 

load panel 

 

 

To add a quadrilateral load panel 

ü Choose Add 4-node Load Panel from the Geometry menu 

ü Click in anti -clockwise order the four nodes that define the corners of the 

panel. 

 

 

 

To automatically add load panels between all of the members in a planar region (eg a 

floor or frame) 






























































































































































































































































































































































































































































































