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License & Copyright 

Prefit Program  
© 1987-2011 Formation Design Systems Pty Ltd 
Prefit is copyrighted and all rights are reserved. The license for use is granted to the 
purchaser by Formation Design Systems as a single user license and does not permit the 
program to be used on more than one machine at one time. Copying of the program to 
other media is permitted for back-up purposes as long as all copies remain in the 
possession of the purchaser. 
 
Prefit User Manual  
© 2011 Formation Design Systems Pty Ltd 
All rights reserved. No part of this publication may be reproduced, transmitted, 
transcribed, stored in a retrieval system, or translated into any language in any form or 
by any means, without the written permission of Formation Design Systems. Formation 
Design Systems reserves the right to revise this publication from time to time and to 
make changes to the contents without obligation to notify any person or organisation of 
such changes. 
 
DISCLAIMER OF WARRANTY 
Neither Formation Design Systems, nor the author of this program and documentation 
are liable or responsible to the purchaser or user for loss or damage caused, or alleged to 
be caused, directly or indirectly by the software and its attendant documentation, 
including (but not limited to) interruption on service, loss of business, or anticipatory 
profits. No Formation Design Systemsô distributor, agent, or employee is authorised to 
make any modification, extension, or addition to this warranty.  
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About this Manual 

This manual describes Prefit, an application that may be used to input existing hull 
designs into Maxsurf. The manual is organised into three chapters. 
 
Chapter 1 Introduction  
Contains a description of Prefit and its interface to Maxsurf. 
 
Chapter 2 Using Prefit 
Explains how to use Prefit's powerful fitting routines to best advantage. 
 
Chapter 3 Prefit Reference 
Gives details of each of Prefit 's windows, toolbars and menu commands. 
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Chapter 1 Introduction 

Prefit provides a means of keyboard entry of existing offset data for use in the 
generation of a three dimensional surface. The surface generated by Prefit may be saved 
as a Maxsurf design file. Offset data may also be loaded from a text file or copied from 
a spreadsheet. 
 
You may find it easier to use the fitting functions provided in the Markers menu in 
Maxsurf rather than using the standalone version of Prefit. 
 
Using Prefit is a three-stage process, entering the bow and stern shapes, fitting the 
transverse splines, and fitting the surface. 
 

Prefit and Maxsurf 

The Prefit licence enables you to access many useful fitting tools directly from Maxsurf. 
The features include a sophisticated automatic fitting tool which uses advanced 
techniques to produce an accurate fit to marker data as well as a usable control point net. 
There are also other tools for fitting corner points and edges to markers. 
 
These are included in the Markers menu in Maxsurf. Please refer to the Maxsurf manual 
for full details of these functions. 
 

Bow and Stern Shapes 

In the first stage, the bow and stern shapes are specified by entering their offsets. This is 
followed by the offset data for all remaining stations. 
 
All offsets appear in the same way as Markers in Maxsurf. 
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Transverse Splines 

Once the markers to be fitted have been entered, a set of transverse splines is generated 
through the markers on a station-by-station basis. Control points to these splines may 
also be displayed allowing for manual fairing of the splines. 

 

 

Fitting a Surface 

When you are satisfied that the splines fit the marker data, you may then fit a complete 
surface through the transverse splines. The surface may then be saved as a Maxsurf 
design file. 
 
If necessary, the surface net may be refined manually to obtain a better fit to the 
markers. 

 

 
Prefit is not suitable for modelling discontinuities in designs such as the hard chined hull 
shown below. 
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Designs featuring chines or discontinuities should be modelled as independent surfaces. 
The above design should be modelled as below, using two Prefit surfaces, with the chine 
as a common surface edge. Once the two surfaces have been fitted, they can be merged 
together in Maxsurf. 

 

Prefit allows you to choose how many control points you wish to use to model the hull 
surface. The choice of the number of control points to use in the generation of a surface 
and its net is a matter of trial and error, as different designs will require different 
numbers of control points. As a rough guide, use slightly more control points than you 
would use to model a similar hull in Maxsurf. 
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Chapter 2 Using Prefit 

You have been introduced to the way in which Prefit works and can now go on to learn 
in detail how to use Prefit by following the example outlined in this chapter. 
 
The example uses a simple yacht hull form whose markers are supplied in a Prefit 
markers file, with extension ó.pfdô, called óPrefit Sample_YachtOffsetsô. This file may 
be found in the óSample Designsô folder. 
 
The example goes through the steps needed to generate a surface from these markers. 

Getting Started 

Install Prefit from the CD. Prefit may then be started, and will display the Perspective, 
Plan, Profile, Body Plan, Markers and Control Points windows. 

Opening a Markers File 

Choose Open Marker Data from the File menu. Select the file titled óYacht Offsetsô and 
open it. This file contains a table of markers for a simple yacht hull form. When it is 
read in, it will fill the Markers window with marker data, and the markers will be 
displayed in the Plan, Profile, Body Plan and Perspective views. Each marker point is 
displayed as a cross in the view windows. 

 

To edit the markers, bring the Markers/Offsets table to the front by choosing Markers 
from the Window menu. The markers are displayed in a table and you can scroll through 
the data to examine the markers at any station. 
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The Markers window is similar to the Markers window in Maxsurf. The column 
headings are: Position (longitudinal position); Offset (transverse position) and Height 
(vertical position). The markers are grouped in stations. The first and last groups, or 
fields, are labelled Bow and Stern in the Station column. 
 
These two groups allow the specification of the bow and stern shape that do not 
necessarily lie on an individual, planar station, as is the case with the other station 
fields. 
 

 

The bow and stern definitions are important as they describe the fore and aft edges of 
the surface that you will create using Prefit. Note that the longitudinal position of each 
bow and stern marker may be changed, allowing either to be raked; in general all other 
sections are vertical (i.e. specified with a constant station position). Markers for each 
station should be entered in order starting at the centreline and moving out towards the 
sheerline. Similarly, markers for the bow and stern should start at the keel and move 
towards the sheerline. 
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Generating Markers Stations in Maxsurf 

Additional functions in Maxsurf version 12 and later can greatly simplify the process of 
getting the markers into their correct order for most designs. After for example 
importing DXF markers or digitising a Linesplan in Maxsurf (see Maxsurf manual for 
instructions), you may have a number of Marker stations and perhaps a bow and transom 
shape described by markers. 
 
Use the Markers | Generate Grid from Markers in Maxsurf to sort markers into stations 
and order them automatically. If you have sloping sections, you should specify a 
minimum of more than one Marker to define a station and perhaps loosen the tolerance 
value: 

 

To help verify that you have the markers in the correct order, turn on Connect Marker 
Stations (Display | Markers menu). And display all the markers. The first marker for 
each station will be shown in bold when the Connect Marker Stations option is turned 
on. 

 

Correctly sorted markers. 

It will still be necessary to manually add ñstationsò for the stem and stern and to assign 
the correct station index to these markers. There is a variety of additional tools for 
correcting marker-ordering problems ï see the Maxsurf manual for details. 
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Transferring markers to Prefit 

Transfer the markers to Prefit by going to the Markers table and saving the table as a 
tab-delimited text file (Save Markers Asé). 

 
Open the Prefit Program and select File | Open Text to load the markers that you just 
saved in Maxsurf. 

 
Prefit should show a similar view, but the markers will be mirrored: 

 

Control Points 

When choosing the number of control points to be used in the surface net you should 
observe the following: 
 
1. The number of stations entered should exceed the number of control point columns. 
2. The number of markers, for the station with the smallest number of markers, should 
exceed the number of control point rows. 
 
A surface net with 6 control point columns and 4 control point rows is shown below; the 
square boxes indicate the net control points. 

 

To set the number of control points and other surface properties, choose Control Points 
from the Surface menu. 
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A dialog will appear which allows you to enter the number of control points transversely 
across the surface (rows) and longitudinally along the surface (columns).  
 
For the example yacht data, set both the number of control point rows and columns to 7, 
as the markers feature a large variation in sectional shape over the length. 

Convergence Limits 

The Control Points dialog also contains several other items, headed Limits and 
Constraints. These limits control how much time Prefit will spend trying to fit splines or 
a surface to your markers. You can instruct Prefit to iterate to improve the quality of fit 
until the maximum error at any marker point is less than a certain level. At the same 
time it is necessary to tell Prefit the maximum number of iterations to make before it 
gives up. 
 
For the moment, set maximum error to 10 mm. and iterations to 5. 

Iterations 

After the initial surface fitting, further iterations of the surface fitting procedure may be 
carried out to obtain a better fit. To do this, select Regenerate Surface from the Surface 
menu. The surface net may also be manipulated manually between iterations to achieve 
a smoother and more useable net. 
 
The net may be displayed by selecting Net from the Display menu. The control points 
may be changed by directly dragging the points in the Plan, Profile or Body Plan views 
or by typing their positions in the Control Points table. Dragging may be constrained to 
either the vertical or horizontal direction by holding the shift button down. 

Constraints 

Constraints restrict control points to lie within certain areas to improve the regularity of 
the control point net that is generated.  
 
The constraints available are: 
 

Flat Bottom.  

This prevents any control points in a particular column being below the level of 
centreline at that position. This is a reasonable constraint for the vast majority of 
hull designs, the only exceptions being those tunnel hulls or concave bottoms. 
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Flat Side.  

This prevents control points from going further from the centreline than the 
widest point at the sheerline.  Only hulls with tumblehome in their topsides would 
need to have this option turned off. 

 

Surface Columns.  

This option constrains columns in the fitted surface net to a particular 
arrangement. For example, if a design has a lot of longitudinal curvature in the 
bow it is reasonable to constrain the control point columns so that they are 
concentrated more in the bow. If a hull shape has fairly even curvature from bow 
to stern, Even Spacing or no column constraint at all is acceptable. 
 
If the Surface Columns constraints box is ticked, the desired control point 
distribution may be selected from the Control Point Distribution radio buttons. 

 
For the sample hull, all the Constraints may be left on. 

Flexibility 

Before generating splines through the markers, it is necessary to set the flexibility of the 
splines to be used. Order 4 splines are most suited to the generation of surfaces in Prefit. 
As you gain experience with the program you may wish to experiment with other spline 
stiffnesses.  
 
Click the OK button in the Control Points dialog to accept the changes and close the 
dialog. 

Sections 

Next choose the Body Plan window from the Window menu. 
 
When fitting the transverse splines you will need to show individual sections. As in 
Maxsurf, either all the sections or just the current section may be displayed depending 
on whether the Sections option is on or off. Select the Sections tick box in the Contours 
dialog to turn on all sections; remove the tick to view only the current section. 
 
The contours dialog is activated by selecting Contours from the Display menu. 
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Remove the tick from the stations check box so that only the current section is 
displayed. 
 
As in Maxsurf, the current section is chosen from the inset box in the Body Plan view to 
display the section and markers for the current section. 

 

Fitting Splines 

Now that you have set the flexibility of the splines to be used, you can fit the splines 
through the markers by choosing Section Splines  from the Display menu. This will 
calculate all the splines and display the spline, which has been fitted through the current 
section. Selecting Edge Splines from the Display menu will calculate and display the 
splines, which are fitted through the sheerline and keel. 
  
Once Prefit has calculated the spline, it will be drawn as a solid line through, or very 
close to, the marker points.  
 
If you wish you can modify any spline control point. To do this, select Spline Controls 
from the Display menu. Spline Controls shows the control points for the spline as 
generated by Prefit. You can drag the control points with the mouse to modify the fit of 
the spline to the marker points. The movement may be constrained to the vertical or 
horizontal direction by pressing the shift key while dragging the control point. 
 
Remember that if you are only showing one section at a time, you can change the 
current section by clicking on the desired station marker in the inset box at the top right 
of the Body Plan window. 
 
When modifying the bow and stern definitions be sure to refer to the Plan and Profile 
windows to check for fairness as well as in the Body Plan window. 



Chapter 2 Using Prefit 

Page 15 

 

Profile and Plan views showing control points with constant longitudinal position for intermediate stations and 
a completed definition of the bow and stern. 

The splines generated through the top and bottom edges of the surface (normally keel 
and sheerline) may be manipulated in a similar manner. 

Generating a Surface 

Now that you have automatically and manually fitted the splines to the points, you can 
go ahead and generate the surface. Note that Prefit does not fit the surface to the marker 
points but to the splines, which have been fitted to the points. Choose Generate Surface 
from the Surface menu to fit the surface. 
 
The calculation of a surface may take some time, as it is a complex mathematical 
problem. The time taken depends on the size of the required control point net. The larger 
the net, the greater the time taken to fit the surface. To speed up the process, fewer 
initial iterations can be specified. At a later stage, subsequent iterations may be 
calculated to refine the surface if greater accuracy is required. Chose Regenerate 
Surface from the Surface menu to do this. 
  
The resulting surface will be displayed superimposed over the original splines to check 
for the accuracy of the fit. 
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You may save the surface by selecting Save Surface As from the File menu. The surface 
will be saved as a Maxsurf design file and may then be opened in Maxsurf. The markers 
will also be saved and can be viewed in Maxsurf. 
 
After the surface has been generated you may display the net to see if the result is a net 
that is clean and easily usable in Maxsurf. Choose Net from the Display menu to display 
the net. 

Creating a Markers Table 

Now that you have learned how to generate a surface from a table of markers, you can 
start to create your own table of markers as you would for a new design. 
 
Choose Close Marker Data from the File menu to close the table of yacht markers you 
have been working with. 
 
Next, select New Marker Data from the File menu and you will be presented with a 
dialog box in which you may input the four corners of a new surface.  

 

These corners are input as óBow at deck edgeô, óBow at footô, óTransom at deck edgeô, 
and óTransom at keelô. You may also enter the number of points you intend using in the 
definition of the bow and in the definition of the stern, including the edge points. 
 
The remaining stations may then be entered in the Markers window and the splining and 
surface fitting performed as in the preceding example. Choose Markers from the 
Window menu to bring the Markers window to the front. 

Editing Markers 

All cells in the Markers table are editable except: 

¶ The column titles  

¶ The row numbers  

¶ The station column  

 
Under most circumstances, it is desirable to have vertical stations (except for the Bow 
and Stern). However, it is possible to have non-vertical stations. 
 
To change the number in a cell, simple click on the cell to select it and then type in the 
new number. You can use the tab key to move to the next cell to the right and the Return 
key to move to the cell below. You can also use the arrow keys to move around in the 
table. 
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In order to add and delete information from the table of markers, it is necessary to select 
cells and rows in the table. 

Selecting a Cell 

Clicking in a cell selects that individual cell and highlights it. When an editable cell is 
selected new data may be entered from the keyboard. The data may be input in any units 
and Prefit converts to the current units as set in the Units option of the Display menu.  
 
Append the appropriate unitôs symbol to enter data, which is not in the current units. See 
Data Menu | Units in the Reference section for further details. 

 

Selecting a Row 

Clicking on a row number selects that row. When a row is selected a marker may be 
inserted or removed from the marker definition of the surface. 
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Selecting a Column 

Clicking in a column title selects that column. A selected column may be copied to the 
clipboard or may have the contents of the clipboard pasted into it. 

 

Selecting all Markers 

Clicking in the Sheet Select box (top left cell of table) selects the entire Markers 
window. This is useful only to copy the entire Markers window. 

 

Apart from the basic numerical editing of individual cells, operations may be performed 
on whole rows or individual stations in the Markers window. 
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Holding down the shift key while copying data from the table, will also copy the column 
titles. 
 
On Windows, various other features relating to the table may be selected from the 
context menu, which is activated by óright clickingô in the table window. 

Inserting a Marker 

To insert an marker at a given station: 

¶ Select a row in the table. The marker will be inserted immediately below this row.  

¶ Select Add Marker from the Edit Menu.  

 

Deleting a Marker 

To delete an marker from the table: 

¶ Select the row of the marker to be deleted.  

¶ Select Delete Marker from the Edit Menu.  

 

Adding a Station 

To add a new station to the table: 

¶ Choose Add Station from the E dit menu.  

¶ A dialog box will appear allowing you to enter the position of the station and the 

number of markers you require at this station.  

 

¶ Enter the longitudinal position of the station and the number of markers you 

require at this station.  

¶ Click OK.  

The new station will be inserted in the table at the correct location. 

Deleting a Station 

To delete a station from the table: 

¶ Choose Delete Station from the Edit menu.  

¶ A dialog box will appear:  

 

¶ Enter the numbers of the first and  last stations to be deleted. To delete a single 

station enter the same number in the From and To boxes.  

¶ Click OK.  

All of the markers for these stations (inclusive) will be removed from the table. 
























