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License & Copyright 

Section Maker Program  

© 1985-2007 Formation Design Systems 

Section Maker is copyrighted and all rights are reserved. The license for use is granted to 

the purchaser by Formation Design Systems as a single user license and does not permit 

the program to be used on more than one machine at one time. Copying of the program 

to other media is permitted for back-up purposes as long as all copies remain in the 

possession of the purchaser. 

 

Section Maker User Manual  

© 1985-2007 Formation Design Systems 

All rights reserved. No part of this publication may be reproduced, transmitted, 

transcribed, stored in a retrieval system, or translated into any language in any form or by 

any means, without the written permission of Formation Design Systems. Formation 

Design Systems reserves the right to revise this publication from time to time and to 

make changes to the contents without obligation to notify any person or organization of 

such changes. 

 

 

DISCLAIMER OF WARRANTY 

Neither Formation Design Systems, nor the author of this program and documentation 

are liable or responsible to the purchaser or user for loss or damage caused, or alleged to 

be caused, directly or indirectly by the software and its attendant documentation, 

including (but not limited to) interruption on service, loss of business, or anticipatory 

profits. No Formation Design Systems distributor, or agent, or employee is authorized to 

make any modification, extension, or addition to this warranty. 
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About this Manual 

This manual is about Section Maker, a section properties calculation and design system. 

Section Maker works with the Multiframe range of structural design software. 

 

Chapter 1  

Introduction 

Provides an overview of the program and introduces you to some important concepts 

used within the program. 

 

This chapter also discusses the numerical methods used by Section Maker. It is important 

for you to understand these methods and their limitations before using Section Maker for 

sections properties calculations.  

 

Chapter 2  

Learning Section Maker 

Gets you started drawing, calculating properties and installing a section in the 

Multiframe Sections Library. In this chapter you will find a series of exercises designed 

to help you learn the basics of Section Maker and become confident in using it to design 

your own custom sections. 

 

Once you are familiar with the basic concepts used, you may refer to the step-by-step 

instructions in Chapters 3, 4 and 5. 

 

Chapter 3  

Using Section Maker 

This chapter introduces the basic techniques used to interact with the various windows in 

Section Maker. 

 

Chapter 4  

This chapter explains most of the tasks you will carry out in designing and installing a 

new section into the sections library. 

 

Chapter 5 

Sections Library Management 

Section Maker is also used to manage the content of Multiframe Section Libraries. This 

chapter describes how to edit the data in the library, how to add new sections and new 

groups of sections. 

 

Chapter 6 

Section Maker Reference 

Gives an overview of the operations of Section Maker and a summary of the commands 

used.  





 

Page 3 

Notation 

The following notation has been adopted within Section Maker. 

Material Properties 

 

Property Description 

E Young's Modulus 

G Shear Modulus 

n Poissonôs ratio 

Fy Yield Stress 

Fu Ultimate Stress 

Dimensions 

 

Property Description 

D Depth 

B Width (or breadth) 

tw Web thickness 

tf Flange thickness 

 

Fillet radius Radius of fillets in the section 

Toe radius Radius of toes in the section 

d1, d2 Minor depth dimensions 

b1, b2 Minor width dimensions  

taper Taper angle 

 

xl Position of left extent of section 

xr Position of right extent of section 

yt Position of top extent of section 

yb Position of bottom extent of section 

Section Properties ï Japan/International 

 

Property Description 

Mass Mass per unit length 

Area Cross sectional area 

P Distance around perimeter of section 

xc, yc Position of centroid 

xs, ys Position of shear centre 

Ix Moment of inertia about x axis 

Iy Moment of inertia about y axis 

J Torsion constant 

Iw Warping constant 

Zxt Elastic Modulus about x axis at top of section 

Zxb Elastic Modulus about x axis at bottom of section 

Zyl Elastic Modulus about y axis at left of section 

Zyr Elastic Modulus about y axis at right of section 

rx Radius of gyration about x axis 

ry Radius of gyration about y axis 
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Property Description 

Ixc Mmt of inertia about x axis through centroid 

Iyc Mmt of inertia about y axis through centroid 

Ixyc Product of inertia about centroid 

I1 Mmt of inertia about major axis through centroid 

I2 Mmt of inertia about minor axis through centroid 

Ø Angle of major axis from x axis 

Asx Shear area for shear in the minor (x) direction 

Asy Shear area for shear in the major (y) direction 

Z1t Elastic Modulus about principal axis at top of 

section 

Z1b Elastic Modulus about principal axis at bottom of 

section 

Z2l Elastic Modulus about minor principal axis at left 

of section 

Z2r Elastic Modulus about minor principal axis at right 

of section 

xp, yp Position of plastic axis 

Sx Plastic Modulus about x-axis 

Sy Plastic Modulus about y-axis 

S1 Plastic Modulus about major principal axis 

S2 Plastic Modulus about minor principal axis 

  

Section Properties - United States 

 

Property Description 

Mass Mass per unit length 

Area Cross sectional area 

P Distance around perimeter of section 

xc, yc Position of centroid 

xs, ys Position of shear centre 

Ix Moment of inertia about x axis 

Iy Moment of inertia about y axis 

J Torsion constant 

Cw Warping constant 

Sxt Elastic Modulus about x axis at top of section 

Sxb Elastic Modulus about x axis at bottom of section 

Syl Elastic Modulus about y axis at left of section 

Syr Elastic Modulus about y axis at right of section 

rx Radius of gyration about x axis 

ry Radius of gyration about y axis 

Ixc Mmt of inertia about x axis through centroid 

Iyc Mmt of inertia about y axis through centroid 

Ixyc Product of inertia about centroid 

I1 Mmt of inertia about major axis through centroid 

I2 Mmt of inertia about minor axis through centroid 

Ø Angle of major axis from x axis 

Asx Shear area for shear in the minor (x) direction 

Asy Shear area for shear in the major (y) direction 

S1t Elastic Modulus about principal axis at top of 

section 
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Property Description 

S1b Elastic Modulus about principal axis at bottom of 

section 

S2l Elastic Modulus about minor principal axis at left 

of section 

S2r Elastic Modulus about minor principal axis at right 

of section 

xp, yp Position of plastic axis 

Zx Plastic Modulus about y axis 

Zx Plastic Modulus about zaxis 

Z1 Plastic Modulus about major principal axis 

Z2 Plastic Modulus about minor principal axis 

R0 Polar radius of gyration about shear centre 

(See AISC LRFD Appendix E) 

H Flexural Constant 

(See AISC LRFD Appendix E) 

Section Properties ï Europe (Eurocode) 

 

Property Description 

Mass Mass per unit length 

Area Cross sectional area 

P Distance around perimeter of section 

yc, zc Position of centroid 

ys, zs Position of shear centre 

Iy Moment of inertia about x axis 

Iz Moment of inertia about y axis 

It Torsion constant 

Cw Warping constant 

Wel.y.1 Elastic Modulus about y axis at top of section 

Wel.y.1 Elastic Modulus about y axis at bottom of section 

Wel.z.2 Elastic Modulus about z axis at left of section 

Wel.z.2 Elastic Modulus about z axis at right of section 

Iy Radius of gyration about y axis 

Iz Radius of gyration about z axis 

Iyc Mmt of inertia about y axis through centroid 

Izc Mmt of inertia about z axis through centroid 

Iyzc Product of inertia about centroid 

Iu Mmt of inertia about major axis through centroid 

Iv Mmt of inertia about minor axis through centroid 

Ø Angle of major axis from x axis 

Asy Shear area for shear in the minor (y) direction 

Asz Shear area for shear in the major (z) direction 

Wel.u.1 Elastic Modulus about principal axis at top of 

section 

Wel.u.2 Elastic Modulus about principal axis at bottom of 

section 

Wel.v.1 Elastic Modulus about minor principal axis at left 

of section 

Wel.v.2 Elastic Modulus about minor principal axis at right 

of section 

yp, zp Position of plastic axis 
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Property Description 

Wpl.y Plastic Modulus about y-axis 

Wpl.z Plastic Modulus about z-axis 
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Chapter 1  
Introduction 

This chapter provides a brief introduction to Section Maker. 

¶ About Section Maker  

¶ Installing Section Maker  

¶ Section Property Calculations  

¶ Interaction with Multiframe  

 

About Section Maker 

Section Maker may be used to calculate the sectional properties of arbitrary structural 

shapes and install them as sections in the Multiframe Sections Library.  

System Requirements 

Section Maker will run on any Windows ME/2000/XP computer with at least 32 Mb of 

memory for Windows ME and 64Mb for Windows 2000 or Windows XP. 

Installing Section Maker 

Section Maker is installed as part of the Multiframe Suite installer. For instructions, 

please see: http://www.formsys.com/installation or the installation guide on the 

installation CD. 

Starting Section Maker 

After installation, Section Maker should be accessible through the Start Menu. Simply 

select Section Maker from the Multiframe menu under the Start menu. 

Section Property Calculations 

It is important that you understand the techniques used by Section Maker to calculate 

section properties. Before using the program, you should read the remainder of this 

chapter to ensure you understand how to model sections to get accurate results. 

Overlapping Shapes 

If you create a section that is composed of a number of shapes you should be aware of 

how Section Maker treats these for calculation purposes. 

 

First, don't partially overlap shapes, the properties won't be computed correctly. You may 

have a shape completely inside another or completely separate but they may not partially 

overlap. 

http://www.formsys.com/installation
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Exact and Approximate properties 

Most section properties computed by Section Maker are exact and are based upon the 

theory of plane areas. However, some properties cannot easily be computed for arbitrary 

section shapes and so it is necessary for Section Maker to identify a shape as one of the 

standard shapes. The following properties will only be determined correctly when 

Section Maker has identified a section as a standard section shape. 

¶ Shear Are as 

¶ Torsion Constant and Torsion Modulus  

¶ Warping Constant  

¶ Shear Centre and derived properties  

IMPORTANT: Non -standard shapes  

When Section Maker does not identify the section drawn within the shape 

window as one of its standard section shapes some properties will not be 

computed correctly. When installing a section of unknown shape to the 

sections library the user should review the value of the following properties 

to ensure their accuracy. 

Shear Areas ï Approximated as gross area of section 

Torsion constant ï Approximated as sum of torsion constant of shapes 

Warping Constant ï Set to Zero 

Shear Centre ï Assumed to be coincident with centroid 

H, r0 ï LRFD properties based upon shear centre. 

Composite Sections 

For a section composed of more than one material, Section Maker computes modulus 

weighted section properties as described in Pilkey. In determining the elastic properties 

of a section, the modulus weighted concept scales the properties of the individual shapes 

forming the section by the ratio of the elastic modulus of the shape and the elastic 

modulus of a reference material. 
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For example, a reinforced concrete section, Section Maker would default to using 

concrete as the reference material. In determining the overall properties of the section, 

the properties of the steel shapes would be factored by the modular ratio Es/Ec where Es 

is the Young's Modulus of the steel and Ec is the Young's Modulus of the concrete. 

 

The calculation of the plastic properties, such as the plastic modulus, for a composite 

section uses a similar concept. Instead of scaling the properties of shapes by the ratio of 

the elastic moduli, the properties are factored by the ratio of the yield strength of the 

shape to the yield strength of the reference material. 

Interaction with Multiframe 

When constructing a frame in Multiframe it is often necessary to use Section Maker to 

design the sections shapes used within the model. There are a number of ways to share or 

transfer data from Section Maker for use in Multiframe. 

Sharing a library 

Section Maker and Multiframe can open the same sections library simultaneously. As the 

sections library is a file, care must be exercised to avoid overwriting changes made in 

one program with changes made in the other. The simplest way to avoid this is to always 

modify the sections library using Section Maker and reload the updated library into 

Multiframe in order to use the new sections. 

IMPORTANT: Using Section Maker with Multiframe  

Be careful when using Section Maker with the Multiframe program open in 

the background. If you have both Section Maker and Multiframe open at the 

same time, any changes you make to the Section Library with Section 

Maker will not be reflected in the sections available to Multiframe until they 

are saved and re-loaded into Multiframe. 

To make any changes to the library available within Multiframe you must  

¶ Save the section library from Section Maker using the Save command  

¶ Switch to Multiframe  

¶ Use Open Library ->Section s Library from the File menu to re -load the saved library 

into Multiframe  

Note that it is not necessary to close the model open within Multiframe when opening the 

sections library. Multiframe will automatically locate sections used within the model 

within the updated library. 

The Frame Group 

In Multiframe, an extra group of sections is added to the end of the sections library. This 

group, named the ñFrameò group, is stored as part of the Multiframe model instead of 

within the sections library. As this group is not accessible from Section Maker, the only 

way of adding a section to this group is via the Add Section command within 

Multiframe. It is then necessary to copy the property data from Section Maker into the 

Add Section dialog open within Multiframe. 

 

To facilitate this and enable the section property data to be readily exchanged, the 

Properties Window in Section Maker contains a table listing the properties of the Frame 

group. These properties can be copied directly from here and inserted into the table 

within the Add Section dialog. Care should be taken to ensure the same units are in use 

within both programs. 
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Chapter 2  
Learning Section Maker 

This chapter provides a tutorial to help you learn the basics of working with Section 

Maker. 

¶ Starting Section Maker  

¶ Drawing a Shape  

¶ Adding the Section to the Sections Library  

 

Starting Section Maker 

Start up the Section Maker program and then use the Drawing Layout command from the 

Window menu to lay out three windows on the screen titled Shape, Properties and Data. 

This will provide you with the most convenient window arrangement for creating new 

sections. 

Drawing a Shape 

To introduce you to the concepts and techniques you will use in Section Maker, this 

chapter will describe the creation of a structural section step by step. The section you will 

draw is shown below.  

 

 

First, you will draw the section to scale, inside the Shape window. Make sure that your 

units are set up correctly by using the Units command from the View menu. This 

example is carried out in American units; you can use other units if you wish. 

 

It is necessary to set up the sizes for drawing in the Shape window.  

ü Choose Sizeé from the View menu.  

A dialog box will appear with four fields in it specifying the maximum dimensions of the 

section. 
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ü Type 4 for the maximum x coordinate and then press the Tab key to move 

to the second field 

ü Type in -4 for the minimum x coordinate and then use the Tab key to 

move to the next two fields entering 6 and -6 for the maximum and 

minimum y coordinates.  

ü Click the OK button when you have finished entering the values.  

If you make a mistake entering the numbers, you can use the backspace key to delete the 

character just to the left of the blinking cursor and you can use the Tab key to move from 

one field to the next. 

Placing a Shape 

To create the I-beam that forms the basis of the section, you can use Section Maker's 

commands for automatically generating a common structural shape. 

 

A note on terminology: 

Section Maker uses the term "section" to refer to a structural cross sectional shape and its 

associated sectional properties that is stored in the Multiframe Sections Library. The 

term "shape" is used to refer to a geometric shape such as a polygon, circle or rectangle 

or an assemblage of these shapes. A section is made up of one or more shapes. 

ü Choose Place Shape from the Shape menu.  

A dialog will appear with a picture of an I shape and fields where you can enter the 

dimensions of the shape. 

 

ü Choose Steel for the material type 

ü Type in 12 for the depth then enter 8 for the width, 0.5 for the flange 

thickness and 0.25 for the web thickness. 

ü Click the OK button  

The I shape will be drawn on the screen centred in the Shape window. The I shape is 

generated as an assembly of three rectangles. The corners of the rectangles will be 

highlighted with small black boxes (called handles) to indicate that the rectangles are 

selected. 
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Note:  

The properties for the section are displayed in the Properties window. 

Placing a Section 

To place the channel on the top of the I shape, you can take an existing channel from the 

Sections Library. 

ü Choose Place Sectioné from the Shape menu 

A dialog will appear allowing you to select a section from the Sections Library 

 

ü Click on the C name in the list of groups 

The names of the channel sections stored in this group will be displayed in the list on the 

right. 

ü Click on the name C10x20 to select this section 

ü Click the OK button 

The dimensions of the section will be taken from the library and the section will be 

drawn in the centre of the Shape window. This C shape will be made up of three 

rectangles modelling the web and two flanges and two shapes modelling the fillets 

between the web and flange. The corners of the placed section will be highlighted to 

indicate that the group of shapes is selected. 

Rotating the Shape 

Before you can place this C shape on top of the I shape, you need to rotate it by 90 

degrees 

ü Choose Rotate é from the Geometry menu 

A dialog will appear allowing you to enter the number of degrees to rotate the shape. The 

angle of rotation is measured in degrees with positive being anti-clockwise  

 

ü Type in -90 for the angle of rotation 

ü Click the OK button  
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The C shape will be rotated so that it is oriented ready to move on to the top of the I 

shape. 

Dragging the Shape 

You can move shapes in Section Maker by dragging them with the mouse. 

 

To drag the C shape 

ü Point anywhere inside the C shape but away from the black boxes, which 

show that it is selected. 

ü Press and hold down the mouse button. 

 

ü Drag the shape until its sits evenly on top of the I shape 

 

ü Release the mouse button. 

As you drag the shape it will be redrawn at its new position 

 

At every change that you make to the section, the new section properties will be 

automatically recalculated and updated in the Properties window. 
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Drawing a Shape 

Now you can draw the additional plate on the bottom flange of the section. 

To make it easier for you to draw the frame, you can use Section Maker's Grid option to 

make drawing automatically align to a grid with regular spacing. 

ü Choose Gridé from the View menu.  

A dialog box will appear with values for the x (horizontal) and y (vertical) spacing of the 

grid. 

 

ü Type 0.5 for the x spacing, use the Tab key to move to the y spacing and 

type 0.5 for it also 

ü Click on the Visible check box to display the grid in the window.  

ü Click on the Snap check box to make subsequent drawing align with the 

grid.  

This will also turn on the Visible button to make the grid visible in the Shape window.  

ü Click on the OK button to confirm your settings. 

Now move the pointer inside the Shape window and notice that as you move the mouse, 

the coordinates of the pointer are shown at the bottom left hand corner of the window. 

The coordinates are shown in the same units as Deflection in the Units dialog. The 

coordinates will automatically align to the nearest point on the grid. You can now begin 

to draw the shape to scale in the Shape window. 

ü Click on the Rectangle tool to select it 

 

ü Press the mouse button at the bottom left corner of the I shape 

ü Drag down and to the right to draw the bottom plate 
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ü Release the mouse button when the plate is the correct size, i.e. when the 

coordinates read x=4, y=-6.5 

Notice that the properties for the rectangle displayed in the Data window are negative. 

This is because as yet no material types have been assigned to that shape. Any shape, 

which does not have a material type, is assumed to be a hole and is subtracted from the 

property calculations. Next we will set the material for the rectangle. 

Selecting Materials 

In order to compute the deflections in a structure, Multiframe needs to know the Young's 

Modulus and Shear Modulus for the materials in the section. You can choose what type 

of material each shape in the section is made of by choosing from the range of materials 

properties stored in the Sections Library. 

 

The rectangle you have just drawn should be selected. If not, select it by clicking on it. 

ü Choose Select Material from the Shape menu 

A dialog box will appear with a list of the materials in the library. 

 

ü Click on the name Steel in the list 

ü Click the OK button  
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This will define the bottom plate to take its material properties from those for steel stored 

in the library. The shapes will be drawn filled with the colour depending on shape type 

and patterned for their material, solid for steel in this case. 

Aligning to the Centroid 

Before you install your section in the Sections Library you will probably want to align 

the Centroid of its area with the x-y axes so that all properties will be calculated relative 

to the Centroid. 

 

To align the Centroid of the section with the axes 

ü Choose Select -> All from the Select sub-menu under the Edit menu 

This will select all the shapes in the section 

ü Choose Align To Centroid->Centroid from the Geometry menu 

All of the selected shapes in the Shape window will be moved so that their common 

Centroid is aligned with the x-y axes. 

ü Choose Size To Fit from the View menu 

This will make the whole section visible in the window. 

 

Once the shapes move, the properties will be automatically recalculated and displayed in 

the Properties window. You can check that the section is aligned with the axes by 

verifying that the coordinates of its Centroid (xc, yc) are 0.000,0.000. 

Adding the Section to the Sections Library 

Now that you have created the section you want, you can install it in the Sections 

Library.  

 

If Section Maker finds a library named "SectionsLibrary.slb" in the same directory as 

Section Maker, it will automatically open it on start-up.  

 

If you have installed Section Maker correctly, this library should automatically have 

been opened. 

ü Choose Add to Libraryé from the Shape menu 

A dialog box will appear with the properties of the section, a list of groups and a list of 

symbols indicating the shape of the section. The section's properties displayed in the 

table will be the same as those calculated in the Data window. If you wish you can 

change them before installing the section in the library. In this case we will leave them 

set to the calculated values. 
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ü Type in a name for the section 

ü Select the name of the group where you would like to store the section eg 

Custom1 

Since it is not one of the standard shapes, in this case we will leave the shape set to the 

ñUnknown Sectionò setting. 

ü Click the OK button  

Viewing Sections 

You can verify that your section has been correctly installed into the library by checking 

its properties in the Section Tables in the Library Window. 

ü Choose Librarie s from the Window menu 

The Library Window will be brought to the front. 

ü Click on the Sections tab at the bottom of the Libraries Window 

Or 

ü Choose Sections from the Library submenu contained in the Data menu. 

Tables of sections are displayed in this window. One group at a time is displayed.  

 

To choose which group to display 

ü Choose Select Groupé from the Library menu 

A dialog box will appear with a list of the names of the groups in the library. 

ü Click on the name of the group you stored your section in eg Custom1 

ü Click the OK button  

The table of sections for that group will be displayed in the Sections table. You can 

check the name and properties are correctly stored by scrolling through the table to view 

the section's name and properties. 

Saving your Work 

You can save the changes you have made to the Section Library by using the Save 

command from the File menu. 
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ü Choose Save Library from the File menu 

The Sections Library will be saved to disk complete with the section you added to it. 

Printing your work 

You can print the shape you have created 

ü Bring the Shape window to the front 

ü Choose Page Setup from the File menu and choose your paper size 

ü Choose Print Window from the File menu 

ü Click the Print button to print out th e shape 

This will print the shape on your printer. You can bring the Properties window to the 

front and use Print Window to print the properties table for the shape. 
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Chapter 3  
Using Section Maker 

If you have read Chapter 1 and 2, you are now familiar with some of the features of 

creating a section using Section Maker. The next three chapters describe all the 

commands available within Section Maker. They present a series of step-by-step 

instructions of the tasks covered in Chapter 2 as well as other procedures you will want 

to know about. 

 

This chapter describes the basics of how to interact with the various windows used 

within Section Maker. 

¶ Summary of Mouse Techniques  

¶ Summary of Keyboard Techniques  

¶ Resizable Dialogs  

¶ Working  

¶ Working in Table 

¶ Printing  

 

Techniques 

This section describes several techniques you can use in Section Maker.  

¶ Summary of Mouse Techniques  

¶ Summary of Keyboard Techniques  

¶ Resizable Dialogs   

 

See also:  

¶ Working in Shapes Window  

¶ Working in Table  Windows  

 

Summary of Mouse Techniques 

You will use the following mouse techniques to do just about all of the tasks in this 

chapter. 

¶ Click to select or activate something  

¶ Press to cause a continuous action  

¶ Drag to select, choose from a menu or move something  

¶ Shift -Click to select or to extend or reduce a selection  

¶ Double -Click t o choose from a dialog box  

 

To Click 

Position the pointer on what you want to select or activate 

Press and quickly release the mouse button 

To Press 

Position the pointer on something 

Without moving the mouse, press and hold down the mouse button. 
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The effects of pressing continue as long as the mouse button is held down. 

Pressing on a scroll arrow results in continuous scrolling. Pressing on a menu title 

pulls down the menu and keeps it down until you release the mouse button. 

To Drag 

Position the pointer on something 

Press and hold down the mouse button and move the mouse 

Release the mouse button. 

To Shift-Click or Ctrl -Click  

Shift-click is used to extend or reduce the selection. In the Shape Window this will 

select or deselect the shapes. Hold down the shift key and click on the shape you 

wish to add to the selection or which you wish to remove from the selection 

To Double-Click 

Double click is used as a short cut equivalent to opening the properties dialog.. 

In the Shape Window, point to the shape you wish to edit and then click twice 

quickly in succession without moving the mouse. 

To Scroll 

In the windows with tabular data, the mouse wheel can be used to scroll the view 

up or down.  

To Zoom 

In the Shape Windows the mouse wheel can be used to dynamically zoom the 

view within the Window.  

To scroll a table one line up or down 

Click the appropriate arrow at the top or bottom of the vertical scroll bar 

To scroll a table one column left or right 

Click the appropriate arrow at the left or right of the horizontal scroll bar 

To scroll a table continuously line by line 

Press the appropriate arrow at the top or bottom of the vertical scroll bar 

To scroll a table continuously column by column 

Press the appropriate arrow at the left or right of the horizontal scroll bar 

To scroll up or down by the windowful 

Click in the grey area above or below the scroll box in the vertical scroll bar. 

To scroll left or right by the windowful  

Click in the grey area to the left or right of the scroll box in the horizontal scroll 

bar. 

To go to the beginning or the end of the table 

Drag the scroll box to the top or the bottom of the vertical scroll bar. 

To go to the left or right hand edge of the table 

Drag the scroll box to the left or the right of the horizontal scroll bar. 

To go to any part of a large table 

Drag the scroll box to a place in the scroll bar that's about equivalent to where the 

data is in the table. 

Summary of Keyboard Techniques 

This section describes keyboard techniques you can use as shortcuts when using Section 

Maker. 
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Tab 

You can use the Tab key to move horizontally within a table or to move from one 

field in a dialog to the next. 

Enter 

The Enter key can be used to confirm the entry of numbers into a table and is the 

same as clicking OK in a dialog. 

Arrow Keys  

The ¬ « ­ ®  keys may be used to move the selection in their respective 

directions in the Data or Result tables. 

Delete (Or Backspace) 

The Delete key may be used to delete the current selection. If nothing is selected 

and you are typing text or numbers, it will delete the character to the left of the 

blinking cursor. In the Shape window it will delete the currently selected shapes. 

Ctrl  

The Ctrl key may be held down while typing another key to choose a command 

from a menu without using the mouse. Menu items, which have a key to the right 

of the name, may be chosen in this way. For example, to choose Undo from the 

Edit Menu you could hold down the Ctrl key and type Z. 

Shift 

You can hold down the shift key while clicking on something to add it to the 

current selection or remove it from the selection if it is already selected. 

 

Holding down the shift while drawing a member, dragging a member or dragging 

a joint will constrain the movement to be horizontal, vertical or at a 45 degree 

angle. 

 

Holding down the shift key while starting up the application will reset the 

application (window sizes, toolbars etc) back to the default settings. 

Scrolling 

Scrolling is a technique for moving a table of data up, down, left or right in a 

window so that you can bring any part of the table into view. 

Resizable Dialogs 

Some of the dialogs in Section Maker can be resized to provide more room for some 

controls within the dialog. Generally dialogs with tables or list boxes will be resizable. A 

small icon in the bottom right hand corner of the dialog (as shown below) identifies 

dialogs that can be resized. 
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Working in Shapes Window 

The Shape Window is the only graphical window in Section Maker. This section 

described the commands used to control what is displayed is the window and how that is 

displayed.  

Zoom 

Zoom allows you to increase the size of the drawing in the Shape window.  

ü Choose Zoom from the View Menu 

ü Move the pointer to the top left hand corner of the area you wish to view 

in close detail 

ü Drag a rectangle down and to the right, which encloses the area of 

interest, and release the mouse button 

The window's contents will be re-drawn to display the part of the shape contained in the 

rectangle you have drawn. 

 

The mouse wheel may also be used to dynamically zoom the view within the Shape 

Window. By moving the mouse wheel, the view will move in or out. 

Pan  

Pan allows you to shift the display of the shape within the window upwards, downwards, 

to the left or right.  

ü Choose Pan from the View Menu. 

The cursor will change to a hand. 

ü Press inside the window and hold down the mouse button 

ü Drag the drawing to its new location.  

ü Release the mouse button to re-draw the contents of the window.  

If not enough memory is available to move the image, a rectangle the size of the window 

will be moved around as you move the mouse. 
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The middle mouse button may also be used to dynamically pan the view within the 

Shape Window. To pan the view, depress with middle mouse button within the view and 

drag the mouse to pan the view. When the desired view is obtain simply release the 

mouse button to stop panning. 

Shrinking the View 

Shrink allows you to decrease the size of the drawing on the screen. 

ü Choose Shrink from the View Menu 

The drawing will shrink down to 50% of its current size and be re-drawn. If the Shift key 

is held down when the Shrink command is selected the drawing will shrink by only 20%. 

Sizing To Fit 

Size To Fit automatically resizes the drawing in the Shape window so that the section 

just fits inside the window in the current view. This is most useful after you have been 

zooming, panning or shrinking as it returns you to a viewing scale that just fits the 

section inside the window. 

Working in Table Windows 

There are 3 windows in Section Maker that display tabular information. The data for the 

library is displayed in tables in the Library Window. Information about the geometry of 

the section drawn in the Shape Window is displayed in the Data window while the 

properties for this section are displayed in the Properties window.  

 

Use the scroll bars on the side or on the bottom of the table to scroll through the table to 

view rows or columns that are not visible.  

 

In this section:  

¶ Column Widths  

¶ Text Styles  

¶ Number Styles  

¶ Changing N umbers or Name  

¶ Selecting Numbers in Tables  

¶ Copying and Pasting Numbers  

¶ Copyin g and Pasting Sections  

 

Column Widths 

If you want to change the width of a column in the table 

ü Press on the line dividing the column's title from the next column 

ü Drag the column divider to make the column wider 

ü Release the mouse button 

Text Styles 

If you wish you can change the font and text size used to display the numbers in the table 

by using the Font command from the View menu.  
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To change the font and/or size of the text in a table 

ü Choose Font from the View menu 

 

ü Click on the name of the font you require 

ü Click on a font size or type in a size 

ü Click the OK button  

Number Styles 

You can also choose what numeric format to use for displaying the numbers by using the 

Numbers command from the View menu. 

 

To change the number of decimal places or the decimal format of the numbers in a table 

ü Choose Numbers from the View menu 

 

ü Choose Decimal or Scientific notation 

ü Type in the number of decimal places you require 

ü Click the OK button  

Changing Numbers or Name 

To change a number or name in a table 

ü Click on the name or number to be changed 

ü Type in a new value 
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ü Press the Enter key 

Selecting Numbers in Tables 

You can also copy and paste data in tables. The copy or paste will act on the current 

selection in the window. You can select a number or a range of numbers, a row or range 

of rows, or a column or range of columns. 

 

To select a number 

ü Click on the number 

To select a range of numbers 

ü Press on the number at the top left of the range to be selected 

ü Drag the mouse until the last number is selected 

ü Release the mouse button. 

If the last number you want to select is outside the window, drag the mouse outside the 

window and the table will automatically scroll to bring the number into view. 

 

To select a row 

ü Click on the number at the left of the row 

To select a range of rows 

ü Press in the number at the left of the first row 

ü Drag down until the last row is selected 

ü Release the mouse button 

If the last row is outside the window, drag outside the window and the table will scroll to 

bring the row into view. 

 

To select a column 

ü Click on the title at the top of the column 

To select a range of columns 

ü Press in the title of the left hand column in the range 

ü Drag the mouse across until the right hand column is selected 

ü Release the mouse button 

If the right hand column is outside the window, drag outside the window and the table 

will scroll to bring the column into view. 

 

To select the whole table 

ü Click in the box at the top left corner of the table 

Copying and Pasting Numbers 

To copy or paste numbers in Section Maker, first select the numbers then choose the 

command you require. 
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To copy a number or range of numbers 

ü Select the numbers to be copied 

ü Choose Copy from the Edit menu 

The numbers will be placed on the clipboard. Each row of numbers will have a return 

character at the end and the numbers in the row will be separated by a Tab character. 

You can transfer data copied from Section Maker into other programs or you can paste 

them into other tables in Section Maker. 

 

To paste the numbers on the clipboard into a table 

ü Select the numbers in the table that will be replaced by the numbers on 

the clipboard 

ü Choose Paste from the Edit menu 

Copying and Pasting Sections 

The Sections Table in the Library Window can be used to copy sections between groups 

or even into the same group.  

 

To copy a section or a number of sections to another group  

ü Select the entire row of the sections to be copied 

ü Choose Copy from the Edit menu 

ü Select a new current group from the Group toolbar or by using the Select 

Groupé command in the Library menu. 

ü Choose Paste Special from the Edit menu 

The copied sections will be appended to the end of the current group. Section Maker will 

maker automatically map the section properties of the sections to the match the fields of 

the group into which they have been pasted. Caution should be exercised when copying 

sections between groups to ensure that section property data is not lost and that the data 

is available for all the fields in the destination group. 

 

Printing 

The contents of any of the windows in Section Maker can be printed and you can also 

print out a complete table of every section in the Sections Library. When printing tables 

they will be printed over multiple pages as there will generally not be enough room on 

one page for all the rows and columns in the table. 

Setting up the Printer 

Before printing you should set up the printer with the page size and orientation that you 

wish to use. 

 

To Set up the Printer 

ü Choose Page Setup from the File menu 
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The standard page setup dialog will appear allowing you to enter the appropriate 

information. You may also enter text to be displayed at the head and foot of each page 

and set the width of the margins on the page. 

Printing a Window 

To print the contents of the front window 

ü Choose Print Window from the File menu 

The standard print preview dialog will appear. Click the Print button to print out the 

contents of the front window. 

Printing the Library 

To print the entire contents of the Sections Library 

ü Choose Print Library from the File menu 

The standard print preview dialog will appear. Click the Print button to print out the 

library. The tables of sections for each group in the library will be printed. If there are 

more rows and columns than will fit one a page the printout will be spread over a number 

of pages.





Chapter 4 ï Working with Shapes 

Page 31 

Chapter 4  
Working with Shapes 

Creating a section with Section Maker involves defining the geometry of the shapes by 

drawing in the Shape window. You can also use the pre-defined generation aids to 

automatically place common structural shapes into the section. 

 

In this section: 

¶ Drawin g a Shape  

¶ Moving a Shape  

¶ Copying and Pasting Shapes  

¶ Resizing a Shape  

¶ Deleting a Shape  

¶ Duplicating a Shape  

¶ Rotating a Shape  

¶ Rescaling a Shape  

¶ Reflecting Shapes  

¶ Making shapes equal in size  

¶ Aligning Shapes  

¶ Stacking Shapes  

¶ Converting Shapes to Polygons  

¶ Shape Properties  

¶ Grouping Shapes  

¶ Aligning to C entroid  

¶ Generating Standard Shapes  

¶ Using Existing Sections  

¶ Importing a Shape  

¶ Setting Materials  

¶ Viewing Properties  

¶ Validating the Shape  

¶ Adding a Section to the Library  

¶ Symbols  

¶ Legend  
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Drawing a Shape  

The shapes, which make up a section, may be drawn directly in the Shape window.  

 

The scale at which this drawing is carried out may be specified by choosing the Sizeé 

command from the View Menu. The maximum and minimum coordinates to be used in 

the x and y directions may be entered and Section Maker will scale these coordinates to 

the current size of the Shape window. All movements in the window are accompanied by 

a display of the current pointer coordinates in the lower left hand corner of the window. 

All coordinates are shown in the current units. You can change units using the Units 

command from the View menu. 

Setting the Size 

Before starting drawing, you will need to set up the drawing area for the size of section 

you intend working with. To do this 

ü Choose Sizeéfrom the View Menué 

A dialog box will appear with the dimensions of the section 

 

ü Enter the maximum and minimum coordinates you wish to use in each 

direction 

ü Click the OK button  

Using the Grid 

Section Maker has a built-in facility to allow you to have your drawing automatically 

align with an evenly spaced grid. You can control the spacing, display and use of this 

grid with the Grid command from the View Menu. 

ü Choose Gridé from the View Menu 

ü Type in values for the x and y spacing of the grid 

ü Click on the On button if you want drawing to align to the grid 

This will switch on the Visible button to make the grid to visible. 

ü Click the OK button  
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If you want to have the shapes automatically align with the grid but don't want to see the 

grid, simply click on the Invisible button before clicking OK. Similarly you can click on 

the Visible button to have the grid displayed as a visual guide but click on the Off button 

to disable the automatic alignment with the grid. 

 

All drawing and dragging in the Shape window will align to the grid while the grid is 

switched on. 

Drawing Tools 

Section Maker has six drawing tools for drawing different types of shapes. A change in 

background colour surrounding the toolôs icon indicates the drawing tool which is 

currently active. If the Arrow tool is selected this allows you to select, move and resize 

shapes with the mouse. 

 

Before you start drawing a new section, if there are any shapes in the Shape window 

Choose Select All from the Select sub-menu under the Edit menu and press the Delete 

key. This will remove the existing shapes. 

Rectangle Tool 

The rectangle tool can be used for drawing solid rectangular shapes or for drawing 

rectangular holes in a section. 

 

To draw a rectangle 

ü Click on the rectangle tool to select it 

 

ü Press at the position of the top left corner of the rectangle you wish to 

draw 

ü Drag down to the right until the mouse points to the bottom right corner 

of your rectangle 

 

ü Release the mouse button 
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If you have the Grid turned on then the corners of the rectangle will align to the grid. The 

new shape will be immediately added to the list of shapes displayed in the Data window. 

Hollow Rectangle Tool 

The hollow rectangle tool can be used for drawing hollow rectangular shapes 

(rectangular or square structural tubing). 

 

To draw a hollow rectangle 

ü Click on the hollow rectangle tool to select it 

 

ü Press at the position of the top left corner of the rectangle you wish to 

draw 

ü Drag down to the right until the mouse points to the bottom right corner 

of your rectangle 

If you have the Grid turned on then the corners of the rectangle will align to the grid.  

 

ü Release the mouse button 

When you release the mouse button a dialog will appear allowing you to enter the wall 

thicknesses of the shape you have drawn 

 

ü Type in values for the web and flange thicknesses 

ü Click the OK button  
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The new shape will be immediately added to the list of shapes displayed in the Data 

window. 

Circle Tool 

The circle tool can be used for drawing solid circular shapes or for drawing circular holes 

in a section. 

 

To draw a circle 

ü Click on the circle tool to select it  

 

ü Press at the position of the centre of the circle you wish to draw 

ü Drag down outwards from the centre until the mouse points to the radius 

you require 

If you have the Grid turned on then the centre and radius of the circle will align to the 

grid. 

 

ü Release the mouse button 

The new shape will be immediately added to the list of shapes displayed in the Data 

window. 

Tube Tool 

The tube tool can be used for drawing hollow circular shapes or tubes. 

 

To draw a tube 



Chapter 4 ï Working with Shapes 

Page 36 

ü Click on the tube tool to select it 

 

ü Press at the position of the centre of the tube you wish to draw 

ü Drag down outwards from the centre until the mouse points to the radius 

you require 

If you have the Grid turned on then the centre of the circle and the position of the circle 

will align to the grid.  

 

ü Release the mouse button 

A dialog will appear allowing you to enter a wall thickness for the tube. 

 

ü Type in a value for the wall thickness 

ü Click the OK button  

 

The new shape will be immediately added to the list of shapes displayed in the Data 

window. 
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Polygon Tool 

The polygon tool can be used for drawing solid polygonal shapes or for drawing 

polygonal holes in a section. Note that the calculation of sections properties for a 

polygon will be accurate for all properties except for the torsion constant J. For convex 

polygons the calculation of J will be a reasonable approximation however for any 

polygon with one or more re-entrant corners the calculation of J can not be relied upon. 

 

To draw a polygon 

ü Click on the polygon tool to select it 

 

ü Click at the location of the first vertex of the polygon 

The first side of the polygon will be drawn as you move the mouse 

ü Click at the location of each of the other vertices of the polygon 

ü Double click at the location of the last vertex to close the polygon or é 

ü Press Enter to close the polygon or é 

ü Click close to the first vertex to close the polygon 

 

If you have the Grid turned on then the vertices of the polygon will align to the grid. The 

new shape will be immediately added to the list of shapes displayed in the Data window. 

Open Polygon Tool 

The open polygon tool can be used for drawing polygonal shapes made of thin material. 

Thin means the thickness of the material is very small compared with the size of the 

shape. This is most useful for modelling structural shapes made from cold rolled thin 

steel or aluminium. 

 

To draw an open polygon 

ü Click on the open polygon tool to select it 
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ü Click at the location of the first vertex of the polygon 

The first side of the polygon will be drawn as you move the mouse 

ü Click at the location of each of the other vertices of the polygon 

ü Double click at the location of the last vertex to complete the polygon or 

é 

ü Press Enter to complete the polygon 

 

If you have the Grid turned on then the vertices of the polygon will align to the grid. The 

new shape will be immediately added to the list of shapes displayed in the Data window. 

Moving a Shape 

You can move a shape by dragging it with the mouse in the Shape window 

 

To move a shape 

ü Point anywhere inside the shape 

ü Press the mouse button 

ü Drag the shape to the new location 

ü Release the mouse button 

Holding down the shift key while you drag will constrain the movement to be vertical or 

horizontal. 

Moving a Number of Shapes 

You can move a number of shapes at once by selecting them and dragging them to the 

new location with the mouse. 

 

To select a shape 
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ü Click on or in the shape with the mouse 

If you have turned off the display of materials, you must click on the boundary of the 

shape rather than inside it. The shapes handles will be highlighted to indicate that it is 

selected. 

 

To add a shape to the current selection 

ü Shift-click on or in the shape  

To move a number of shapes 

ü Select the shapes to be moved 

ü Press on or inside any one of the selected shapes 

If you have turned off the display of materials, you must click on the boundary of a shape 

rather than inside one 

ü Drag the shapes to their new location 

ü Release the mouse button 

The shapes will be re-drawn in their new position. 

Moving Shapes Accurately 

You can also move the selected shapes with great accuracy by using the Move command 

from the Geometry menu. 

ü Choose Move from the Geometry menu 

 

ü Type in the distance to move in each direction 

ü Click the OK button  

Copying and Pasting Shapes 

To copy a shape or shapes in the section 

ü Select the shape or shapes to be duplicated 

ü Choose Copy from the Edit menu or press Ctrl+v 

The selected shapes are placed on the clipboard. To paste the shapes stored on the 

clipboard into the Shape Window  

ü Choose Paste from the Edit menu or press Ctrl+v 

The duplicated shapes inserted into the Shape window slightly offset from there original 

position.  
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Resizing a Shape 

You can change the size of a shape by dragging its handles (the small black boxes which 

appear when it is selected). 

 

To resize a shape 

ü Press on the handle closest to the part of the shape you want to move 

ü Drag the handle to its new location 

ü Release the mouse button 

When you resize a polygon each of the vertices moves independently of the others. 

Deleting a Shape 

To delete a shape or shapes from the section 

ü Select the shape or shapes to be deleted 

ü Press the Delete key or é 

ü Choose Delete from the Edit menu 

Duplicating a Shape 

To duplicate a shape or shapes in the section 

ü Select the shape or shapes to be duplicated 

ü Choose Duplicate from the Geometry menu 

A dialog box will appear allowing you to specify the spacing of the duplicated shapes 

and how many are to be created 

 

ü Type in the spacing in each direction and the number of duplicates 

ü Click the OK button  

The duplicated shapes will be drawn and selected in the Shape window. 

Rotating a Shape 

Section Maker allows you to rotate shapes that you have already drawn. Shapes are 

rotated about the axes at an angle measured positive in the anti-clockwise direction. 

Rectangles may only be rotated in increments of 90 degrees. 

 

To rotate a shape or shapes 

ü Select the shape or shapes to be rotated 
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ü Choose Rotate from the Geometry menu 

A dialog box will appear with a field for the angle of rotation 

 

ü Type in the angle of rotation 

ü Click the OK button  

The selected shapes will be rotated about the origin of the axes and re-drawn in the 

Shape window 

Rescaling a Shape 

Section Maker allows you to rescale shapes that you have already drawn. The 

coordinates of the shapes are multiplied by a scaling factor in each direction to rescale 

the shape. 

 

To rescale a shape or shapes 

ü Select the shape or shapes to be rescaled 

ü Choose Rescale from the Geometry menu 

A dialog box will appear with two fields for the scaling factor in each direction 

 

ü Type in the x and y scaling factors 

ü Click the OK button  

The selected shapes will be rescaled and redrawn in the Shape window 

Reflecting Shapes 

You can reflect shapes in Section Maker by using the Flip Horizontal and Flip Vertical 

commands from the Geometry menu 

 

To reflect the selected shapes about a vertical axis passing through the centre of area of 

the selected shapes 

ü Choose Flip Horizontal from the Geometry menu 

 

To reflect the selected shapes about a horizontal axis passing through the centre of area 

of the selected shapes 

ü Choose Flip Vertical from the Geometry menu 
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Making shapes equal in size 

You can also change width or height of a shape by making it equal in size to another 

shape. 

 

To make a shape of a number of shapes equal in width 

ü Select the shapes to be made equal in size. The first shape selected will be 

the dominant shape to which the others will be resized. 

ü Choose Width from the Make Equal Size submenu under the Geometry 

menu, or 

ü Click on the Make Equal Width button in the Geometry toolbar 

Each of the shapes will be resized so that they have the same width as the dominant 

shape. A similar procedure can be followed to make shapes equal in height or equal in 

both width and height by using other commands from the Make Equal Size submenu. 

Aligning Shapes 

The Align commands moves the selected shapes so that the edges or centres of the 

shapes align to the edges or centres of the first shape selected. The Align submenu has 

commands for aligning the top, bottom, left and right hand edges of shapes. It also has 

commands to align the centres of shapes by moving the shapes either horizontally or 

vertically.  

 

To align the left-hand side of a number of shapes 

ü Select the shapes to be aligned. The first shape selected will be the 

dominant shape to which the others will be aligned. 

ü Choose Left from the Align submenu under the Geometry menu, or 

ü Click on the Align Left button in the Geometry toolbar 

Each of the shapes will be moved so that left hand side of each shape is aligned to the 

left hand side of the dominant shape. A similar procedure can be followed to align other 

sides of shapes by using other commands from the Align submenu. 

Stacking Shapes 

The Stack commands, which complement the Align commands, move the selected 

shapes so that shapes are arranged from left to right or top to bottom such that adjoining 

edges aligned to one another. By stacking shapes horizontally, the select shapes will be 

moved so that they are arranged from left to right, the right-hand edge of left most shape 

will be aligned to the left-hand edges of the next and so forth. The first select shape will 

remain in its original position and all the other shapes will be arranged around it. 
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To vertically stack a number of shapes 

ü Select the shapes to be stacked. The first shape selected will be the 

dominant shape about which the others will be rearranged. 

ü Choose Stack Vertically from the Geometry menu, or 

ü Click on the Stack Vertically button in the Geometry toolbar 

Each of the shapes will be moved vertically so that top of one shape is aligned to the 

bottom of the adjacent shape. 

Converting Shapes to Polygons 

Shapes other than polygon shapes can be converted to closed polygons using the Convert 

to Polygon command in the Shape menu. While it is not recommended that shapes be 

converted to polygons, it can be useful to do this in a number of situation such as to 

allow shapes to be rotated by arbitrary angles or to generate complex shapes by merging 

over lapping polygon shapes. 

 

To convert a number of shapes into polygons 

ü Select the shapes to be converted. 

ü Choose Convert to Polygon from the Shape menu. 

Each of the shapes will be converted to a polygon. 

Merging Polygons 

Polygons can be merged together to form complex shapes. Open polygons and closed 

polygons cannot be merged together; they can only be joined to other polygons of the 

same type. Open polygons will be joined to other open polygons only if they have a 

common end point. Closed polygon shapes can be merged with other closed polygons. 

The result may not be a single polygon as the merged shape will take into account which 

polygons are solid and which represent holes in the shape. However, no distinction is 

made between different materials and so any resulting solid polygons will be allocated a 

single material. 

 

To merge a number of polygons 

ü Select the polygons to be merged together. 

ü Choose Merge Polygon from the Shape menu. 

The selected shapes will be merged together to form a number of other polygons. 

Shape Properties 

The properties of any shape can be modified by double clicking on the shape. This will 

open a property dialog that contains the dimensions and location of the shape. This 

dialog may also be opened by selecting a shape and choosing the Properties menu 

command from the Edit menu or the Properties command from the right-click context 

sensitive menu. 
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This dialog also lets you reposition shapes by specifying the location of an anchor point 

on the shape. This makes it easy to align shapes to other shapes within the section. The 

anchor point you choose is moved to the location you enter in this dialog.. For example, 

if you wanted to move a plate to just sit on top of the top flange of a beam, you would 

double click on the plate, choose the anchor point to be Bottom-Centre and set the x 

coordinate to zero and the y coordinate to the height of the top of the flange of the beam. 

Grouping Shapes 

Section Maker allows you to group together shapes within the Shape View. This allows 

shapes to be manipulated together as a single item. This grouping is hierarchical so 

groups may also be grouped inside other groups. 

 

To group together a number of shapes 

¶ Select the shapes to be groupe d 

¶ Choose Group from the Geometry menu  

To ungroup a group of shapes 

¶ Select the shape group  

¶ Choose Ungroup from the Geometry menu  

 

When placing a section or shape within the Shape View, the basic shapes representing 

the section or shape will automatically be grouped together as a single item. When 

placing a section from a library, the group will store the name of the section and display 

this in the Kind column in the Data table. If, however, the shape is ungrouped, this 

information will be lost. 

Aligning to Centroid 

Most times when you create a section you will want to calculate its properties relative to 

a set of axes at the centroid of its area. The Align To Centroid command moves all of the 

selected shapes so that their common centre of area is aligned with the origin of the axes. 

After using Align To Centroid the coordinates of the centroid of the selected shapes will 

always be x=0,y=0. 

 

To align the centroid of a shape or shapes with the axis origin 

ü Select the shape or shapes to be aligned 

ü Choose Align To Centroid from the Geometry menu 

ü Choose from the sub-menu whether to align one or both axes 

The shapes will be moved as a group to centre their area about the axis origin 
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Generating Standard Shapes 

Rather than having to draw common structural shapes such as I beams, channels and 

angles, Section Maker lets you generate such shapes by typing in a few key dimensions. 

 

To generate a standard shape 

ü Choose Place Shape from the Shape menu 

A dialog box will appear with a diagram of the shape and its key dimensions 

 

ü Choose the type of shape you wish to generate 

ü Choose a material for the shape 

ü Type in the dimensions of the shape 

ü Click the OK button  

The generated shape will be placed in the Shape window centred about the origin of the 

x-y axes. 

Fillets and Toes 

If you enter non-zero values for the fillet and/or toe radii, r1 and r2, these radii will be 

modelled as small polygons in the placed shape. This improves the calculation of section 

properties so that the computed values compare very closely to values published by 

manufacturers. The radii of the fillet and toes are also stored in section property fields r1 

and r2 in the sections library. 



Chapter 4 ï Working with Shapes 

Page 46 

 

Using Existing Sections 

If you want to create a section, which is made up from other sections, you can place the 

existing sections using the Place Section command from the Shape menu. You can place 

standard sections from the Sections Library as well as sections you have drawn and 

stored previously. 

 

To place a section 

ü Choose Place Section from the Shape menu 

A dialog box will appear allowing you to pick the section you wish to place 

 

ü Click on the group and section name of the required section 

ü Click the OK button  

The chosen section will be placed in the Shape window. 

Importing a Shape 

If you have a shape in another CAD system you can import it into Section Maker by way 

of a DXF file. 

ü Choose Import DXF from the File menu 

The standard file dialog will appear and you can choose the DXF file. 



Chapter 4 ï Working with Shapes 

Page 47 

Section Maker will extract all the rectangles, circles and polygons from the DXF file and 

place them in the Shape window. If there are lines in the DXF file which form a 

polygonal shape, Section Maker will joint them together at the ends during the import 

process. 

 

Note that Section Maker does not support the import of arcs within polylines in DXF 

files. You should explode the polyline in your CAD system before importing. Also make 

sure to check that the units setting in your cad system matches the units in Section 

Makerôs import dialog. Lastly, ensure that the origin of your coordinate system in your 

CAD system matches the x-y origin in Section Maker. 

Setting Materials 

To enable Multiframe to calculate deflections in structures, values for Young's Modulus 

and Shear Modulus need to be stored with sections in the Sections Library. Section 

Maker takes these values from the materials you choose for the various shapes, which 

make up a section. Section Maker allows you to use a number of different materials 

within the one section. Materials are stored in the Sections Library, standard steel and 

concrete data is included and you can add your own custom materials to the library. 

 

If you do not assign a material to a shape, Section Maker will assume the shape is a hole 

and will deduct its properties from the overall properties of the section. Shapes, which 

are holes, will have negative properties displayed in the Data window. 

 

When shapes you have drawn lie inside each other, you may find it difficult to see which 

is which, especially when the material patterns are displayed in the shapes. You can 

control the order in which the shapes are displayed by using the commands under the 

Arrange sub-menu under the Geometry menu. 

 

To move the selected shapes to the front of all the others 

ü Choose Move To Front from the Arrange menu 

 

To send the select shapes behind all the others 

ü Choose Move To Back from the Arrange menu 

 

To move the selected shapes just in front of the ones currently in front of them 

ü Choose Move Forwards from the Arrange menu 

 

To move the selected shapes just behind the shapes behind it  

ü Choose Move Backwards from the Arrange menu 

Note that shapes can be contained inside other shape e.g. steel bar inside a concrete beam 

or a void inside a beam but shapes cannot overlap partially. See Overlapping Shapes in 

Chapter 4 for more information. 

Setting Material Types 

To set the material type of a shape 

ü Select the shape 

ü Choose Material from the Shape menu 
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ü Click on the name of the material you require 

ü Click the OK button  

See "Adding a Material" below for information on how to add materials to the library. 

Viewing Properties 

When you draw a shape and specify its material properties, as each change is made the 

sectional properties are automatically recalculated and displayed in the Properties 

window 

 

The last row in most of the tables shown in the Properties Window displays the Standard 

Section shape that Section Maker has determined is displayed in the Shape Window. 

This shape is used as the basis for estimating some of the section properties of the 

sections. See Chapter 4 for further details on how Section Maker computes section 

properties. 

 

If you see properties that are displayed in red it means that the shape drawn in the Shape 

Window is not properly constructed and the section properties have not been computed 

correctly. See the Validating the Shape section that follows this section for the rules 

required to ensure the section properties will be computed correctly. 

Validating the Shape 

For Section Maker to correctly evaluate the section properties of the shapes drawn in the 

Shape Window it is necessary for the geometry of the shape to satisfy the following 

criteria. 
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1) A shape cannot be hidden by another shape that is drawn in front of it. If a shape is 

obscured it will be flagged as invalid and ignored when computing the properties of the 

section drawn in the Shape window. 

 

2) A shape can only intersect one other shape. Further, one of these shapes must contain 

the other. 

 

When the shapes drawn in the Shape Window do not meet the above criteria, the values 

of the section properties displayed in the Property Window will be displayed in red. 

Furthermore, any individual shapes that are identified as failing the criteria will be shown 

in red in the Sections table in the Data Window. 

 

Further information about why the section drawn in the Shape Window is invalid can be 

determined using the Validate command. To validate a shape 

ü Choose Validate from the Shape menu 

If the section is invalid, one or more messages will be displayed to the user that identify 

the invalid geometry within the section. Furthermore, if any invalid shapes are detected, 

the selection in the Shape Window will be cleared and the invalid shapes will be 

selected. 

 

In general it is only necessary to use the Validate command if the section properties in 

the Properties Window are displayed in red. 

Adding a Section to the Library 

Once you have drawn a section to your satisfaction, you can install it into the Sections 

Library for later use by Multiframe or Section Maker. 

 

To install your section 

ü Choose Add to Libraryé from the Shape menu 

A dialog box will appear which lets you specify where the section will be stored, a field 

for the name of the section, a table with the calculated section properties and a pop-up 

menu to indicate the shape of the section. 

 

ü Type in a name for the section 
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ü Choose the name of the group where you want to store the section 

ü Choose a shape for the section (or just leave it set to unknown) 

ü If you wish you can change the sections properties to override the ones 

that have been calculated for you. Click on the number to be changed and 

type in a new value. 

ü Click the OK button  

The section will be stored in the library in the group you have nominated. Note that the 

library with the new section included will not be saved permanently on the disk until you 

choose Save Library from the File menu. 

 

If you have Multiframe running, you can now choose Save Library, then switch to 

Multiframe and choose Open Library->Sections Library from the File menu to reload the 

library into Multiframe. This will make the section you have added available for use in 

Multiframe. 

Symbols 

The content of the Shape Window can be modified to annotate shapes with labels, 

display dimensions and axes and to control how the shapes are displayed. 

Shape Numbers 

Each shape in the Shape window can be labelled with its number. To turn on or off the 

display of the shape numbers 

ü Choose Shape Numbers from the Symbols submenu under the Display 

menu, or 

ü Click the Shape Numbers button on the Symbols toolbar 

Polyline Numbers 

Each point along a polyline can be labelled with its index which identifies its positions 

within the polyline. To turn on or off the display of the polyline numbers 

ü Choose Polyline Numbers from the Symbols submenu under the Display 

menu, or 

ü Click the Polyline Numbers button on the Symbols toolbar 

Dimensions 

The overall height and width of the section drawn in the Shape Window can be drawn as 

dimensions. Similarly, the location of the shapes centroid can also be displayed as 

dimensions. To turn on or off the display of the overall size of the section in the Shape 

Window 

ü Choose Overall Dimensions from the Symbols submenu under the Display 

menu 

Or, to turn on or off the display of the centroids location 

ü Choose Interior Dimensions from the Symbols submenu under the 

Display menu 
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Principal Axes 

The principal axes of the shape also be displayed in the Shape Window. To turn on or off 

the display of the principal axes 

ü Choose Principal Axes from the Symbols submenu under the Display 

menu 

Axes 

The origin of the x-y axis system, which represents the location about which the section 

properties are computed, may also be displayed in the Shape Window. To turn on or off 

the display of the these axes 

ü Choose Axes from the Symbols submenu under the Display menu 

These axes are displayed by default. 

Fill 

Shapes within the Shape Window can be represented as either the outline of the shape or 

as a solid object drawn filled. To turn on or off the display of shapes as filled objects 

ü Choose Fill from the Symbols submenu under the Display menu 

When shapes are displayed as filled, the outline of the shapes will be displayed in black 

and the fill colour determine by the colour scheme selected by the user (See the section 

on Colours which follows). Any shapes that have not been allocated a material and 

represent a hole will not be filled and will be drawn using a black outline only. 

 

When shapes are displayed as outlines without any fill, the colour of a shapes outline will 

be determined from the current colour scheme specified by the user. 

Material Patterns 

When shapes are displayed with fill the user has the option of using the pattern 

associated with the shapes material to draw the interior of the shape. To turn on or off the 

display of material patterns 

ü Choose Material Patterns from the Symbols submenu under the Display 

menu 

Legend 

A legend can be displayed that explains the meaning of each colour used to draw shapes 

in the Shape Window. The location and style of the legend can be adjusted using the 

commands in the Legend submenu. 

 

To turn on or off the display of a legend within the Shape Window.  

ü Choose Visible from the Legend submenu under the Display menu, or 

ü Click the Legend button on the Symbols toolbar 

Note that for most colour schemes the contents of the legend is dynamic as will reflect 

only the colour used within the Shape Window. In such cases a legend will not be visible 

until colour has been used.  
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Selecting Shapes 

A feature of the legend is that it can be used to select all the shapes that correspond to a 

particular menu item. To set the selection to all the shapes corresponding to a particular 

legend item simply double click on the text within the legend associated with that item. 

Holding down shift or control while double clicking on the legend item will extend the 

current selection. 

Position 

The position of the legend can be set to any corner of the Shape Window. To display the 

legend in the bottom right hand corner of the window  

ü Choose Bottom Right from the Legend submenu under the Display menu, 

or 

ü Right click on the legend and choose Bottom Right from the popup menu 

A similar procedure can be followed to display the legend in any corner of the screen 

using the commands in the Legend submenu. 

Title Font 

The style of the font used to draw the title of the legend can be set by the used. To 

modify the style of the title font 

ü Choose Title Font from the Legend submenu under the Display menu, or 

ü Right click on the legend and chose Title Font from the popup menu 

 

ü Specify the required colour style in the Font dialog. 

ü Click OK  

Font 

The style of the font used to draw the text of each item in the legend can be set by the 

used. To modify the style of this font 

ü Choose Font from the Legend submenu under the Display menu, or 

ü Right click on the legend and chose Font from the popup menu 
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ü Specify the required colour style in the Font dialog. 

ü Click OK  

Note that the same colour is used to draw both the item text and the title. Changing the 

colour of either font will change the colour of the other text. 

Colours 

The user can modify the colour corresponding to a particular item in the legend. To 

modify the colours associated with an items in the legend 

ü Choose Item Colour from the Legend submenu under the Display menu, 

or 

ü Right click on the legend and chose Item Colour from the popup menu 

 

or 
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ü Select the legend item to be modified 

ü To change the colour of the selected item, click on the Colour box in the 

top left hand corner 

 

ü Choose a new colour from the Colour dialog 

ü Click OK  

The colour of a particular legend item can also be modified by double clicking of the 

colour box associated with that item in the legend.  
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Chapter 5 
Sections Library Management 

This chapter describes the use of all of the commands available in Section Maker that are 

related to the management of sections libraries. It contains a number of sections ï 

¶ Working with Libraries  

¶ Working with Sections  

¶ Working with Groups  

¶ Working  with Materials   

Working with Libraries 

As well as enabling you to draw and add individual sections to the library, Section Maker 

has a number of features that make it easier for you to manage your sections library. You 

can add and remove groups of sections from the library, add or remove a large number of 

sections at once, and store custom or commonly used materials in the library so that they 

are available for use. 

 

You can change the contents of the library in the Library Window. One group at a time is 

displayed in these two windows. The group currently on display is referred to below as 

the current group. In the Groups Table you can view and change the information about 

the current group. In the Sections Table you can view and change any of the section 

properties for any of the sections in the current group. 

 

You can also create completely new libraries or read, modify and write any number of 

sections libraries. This means you can keep a number of libraries on your disk and use 

them for different applications. 

 

In this section: 

¶ Fields and Section Properties  

¶ Creating a New Library  

¶ Opening a Li brary  

¶ Saving a Library  

¶ Saving as Text  

¶ Group Organiser   

 

Fields and Section Properties 

The concept central to the structure of the sections library is that the section property 

data associated with a group of sections should reflect the data tables published by 

manufacturers or industry organisations. With this in mind the data displayed in the 

Sections Table in the Library Window should reflect the published section properties. 

Each column of data in this table represents a field. In order to utilise this data in 

Multiframe it is necessary to identify which section property that a field represents. For 

some types of sections, typically symmetric section, several section properties may be 

mapped to the same field. In addition, a factor must be specified with each field to 

convert the value in the field to the base units of newtons, metres and kilograms. 
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Creating a New Library 

Section Maker allows you to create a new library for use with any of the Multiframe 

applications. All you have to do to make the new library the default is to place it in the 

same folder as the application and name it "SectionsLibrary.slb". If you already have a 

sections library in the folder with that name, rename the existing library to a different 

name and then name your new library "SectionsLibrary.slb". 

 

To create a new library 

ü Choose New Library from the File menu 

A new library will be created with no groups or sections. You can add groups and 

sections to the library (see Adding a Group and Adding a Section below) before saving it 

to disk with the Save As command from the File menu. 

Opening a Library 

You do not have to work with the sections library that automatically opens when Section 

Maker starts up. (If Section Maker finds a library named SectionsLibrary.slb in the same 

folder as Section Maker, it will automatically open it on start-up) If you wish you can 

open any other library and work with it in the normal way. 

 

To open a sections library 

ü Choose Open Library from the File menu 

 

ü Click on the name of the library you wish to open 

ü Click th e Open button 

The contents of the library will be read in and the groups, materials and sections in the 

library will be displayed in the Groups, Materials and Sections tables within the Library 

Window respectively. 

Saving a Library 

If you have installed any sections in the library or you have changed the section or group 

properties in any way, you will have to save the Sections Library to disk to make the 

changes permanent. 

 

To save the Sections Library to disk 

ü Choose Save Library from the File menu 
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To save the Sections Library to disk with a new name 

ü Choose Save As from the File menu 

ü Select the folder or disk where you will save the library 

ü Type in a name for the library 

ü Click the Save button 

Saving as Text 

Another way to view the data in the library is to save it in text format. Text files can be 

read into a word processor or you could write your own software which extracts data 

from a text file of sections. 

 

To save the contents of the library in a text file 

ü Choose Export -> Text File from the File menu 

ü Type in a name for the text file of data 

ü Choose which disk or folder you want to store the data in 

ü Click the Save button 

The complete contents of the sections library will be saved to disk in a text file. The 

format of this file is documented in Chapter 4. 

Group Organiser 

Groups of sections may be copied between section libraries using the Group Organiser. 

The Group Organiser may also be used to delete groups from a sections library. The 

Group Organiser dialog (shown below) provides this functionality by opening two 

sections libraries. The groups in these libraries are listed on either side of the dialog. 

Groups can be copied between the libraries by selecting the group(s) to be copied and 

clicking the Copy button. Similarly, groups may be deleted from a library by selecting 

the groups to be deleted and clicking the Remove Selected Groups button. 
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Any two sections libraries may be displayed in the Group Organiser dialog. By default, 

one of these libraries is set to the current sections library when the Group Organiser is 

first opened. 

 

To import a group of sections from another sections library into the sections library 

currently opened by Section Maker  

ü Choose Group Organiseré from the Library menu 

 

The current sections library is already open in the dialog and displayed down the left 

hand side. 

ü Click the Open Libraryé button on the right hand side of the dialog. 

ü Using the resulting file dialog, choose the sections library from which to 

import the group of sections.  

This section library will be displayed on the right hand side of the Group Organiser 

dialog. 

ü Select the group(s) to be imported to the current library from the right 

hand list of groups. 

ü Click the <<Copy<< button. 

ü Click the left hand Close Library button 

This will save the current library 

ü Click the OK button.  

Working with Groups 

Section Maker allows you to add, delete and modify the groups of sections stored in a 

sections library. 

 

In this section:  
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¶ Viewing Groups  

¶ Locking/Unlocking a Group  

¶ Adding a Group  

¶ Editing a Group  

¶ Duplicating a Group  

¶ Deleting a Group  

¶ Reordering Groups  

¶ Adding a Field  

¶ Editing Fields  

¶ Deleting a Field  

¶ Reordering Fields  

 

Please note that all the commands described in this section are only available when you 

have the Groups tab in the Library window activated. 

 

Viewing Groups 

The groups stored in the Sections Library can be viewed and changed in the Library 

Window of Section Maker. A list of all the groups is displayed in the Groups Table 

within this window. 

 

To make the Groups Table visible 

ü Choose Library from the Window menu 

ü Click on the Groups tab in the navigation bar at the bottom of the 

window. 

 

Locking/Unlocking a Group 

Groups are locked using a checkbox in the ñLockedò column in the Groups tab in the 

library window. To unlock a group, clear the checkbox in the ñLockedò column of the 

Groups tab in the Library window. Groups can also be locked/unlocked via the Group 

Properties dialog. 


















































































